[WPE] Bump deps to add support for xdg-shell-unstable-v6 protocol
authorcommit-queue@webkit.org <commit-queue@webkit.org@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Tue, 3 Oct 2017 20:32:00 +0000 (20:32 +0000)
committercommit-queue@webkit.org <commit-queue@webkit.org@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Tue, 3 Oct 2017 20:32:00 +0000 (20:32 +0000)
https://bugs.webkit.org/show_bug.cgi?id=177820

Patch by Olivier Blin <olivier.blin@softathome.com> on 2017-10-03
Reviewed by Žan Doberšek.

gnome-shell does not advertize the xdg-shell protocol anymore, but xdg-shell-unstable-v6 instead.
Support has been added in WPEBackend-mesa, we need to update the requirements.
wayland-1.10 is needed for wl_proxy_get_version(), used in the generated headers.

* wpe/jhbuild.modules:

git-svn-id: http://svn.webkit.org/repository/webkit/trunk@222804 268f45cc-cd09-0410-ab3c-d52691b4dbfc

Tools/ChangeLog
Tools/wpe/jhbuild.modules

index 6e1932f..2f60ea8 100644 (file)
@@ -1,3 +1,16 @@
+2017-10-03  Olivier Blin  <olivier.blin@softathome.com>
+
+        [WPE] Bump deps to add support for xdg-shell-unstable-v6 protocol
+        https://bugs.webkit.org/show_bug.cgi?id=177820
+
+        Reviewed by Žan Doberšek.
+
+        gnome-shell does not advertize the xdg-shell protocol anymore, but xdg-shell-unstable-v6 instead.
+        Support has been added in WPEBackend-mesa, we need to update the requirements.
+        wayland-1.10 is needed for wl_proxy_get_version(), used in the generated headers.
+
+        * wpe/jhbuild.modules:
+
 2017-10-03  Alex Christensen  <achristensen@webkit.org>
 
         Add ObjC SPI equivalent to WKPageLoaderClient.willGoToBackForwardListItem
index 01ee431..1af8f76 100644 (file)
   <autotools id="wayland"
              autogen-sh="configure"
              autogenargs="--disable-documentation">
-    <branch module="releases/wayland-1.9.0.tar.xz" version="1.9.0"
+    <branch module="releases/wayland-1.10.0.tar.xz" version="1.10.0"
             repo="wayland.freedesktop.org"
-            hash="sha256:9c8770720aa0034479735f58a4dc4ca9b172ecfede28f5134312e135b7301efa"/>
+            hash="sha256:4bf6e790aa6f50ab3825676282ecd75850ec9c4767af96ecb7127b1f3c3d60dc"/>
   </autotools>
 
   <cmake id="wpe">
       <dep package="xkbcommon" />
     </dependencies>
     <branch repo="github.com" module="WebPlatformForEmbedded/WPEBackend-mesa.git"
-            tag="b6e2a82dfd5a12761911dc890625ec81d2a012b4" />
+            tag="0286aed84a09120de16c3ab08bdf83c91d4a1754" />
   </cmake>
 
   <autotools id="libgpg-error" autogen-sh="configure">