Class Proxy can't be extended
authorgskachkov@gmail.com <gskachkov@gmail.com@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Thu, 1 Jun 2017 15:04:53 +0000 (15:04 +0000)
committergskachkov@gmail.com <gskachkov@gmail.com@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Thu, 1 Jun 2017 15:04:53 +0000 (15:04 +0000)
commit29de1f31984ac007ee3ede664cc00ce7775d3f95
treea58f9647e83cc29a470dc8b13c771da8513f57ae
parentb99a0dc0d24d40717f16dd3b61ca5bfa3dd2d643
Class Proxy can't be extended
https://bugs.webkit.org/show_bug.cgi?id=169040

Reviewed by Saam Barati.

Adding tests that check correctness of Proxy to ES6 `class`
Bug is already fixed in https://bugs.webkit.org/show_bug.cgi?id=164849

* stress/proxy-class.js: Added.
(assert):
(throw.new.Error.SuperClass):
(throw.new.Error.A):
(throw.new.Error):

git-svn-id: http://svn.webkit.org/repository/webkit/trunk@217655 268f45cc-cd09-0410-ab3c-d52691b4dbfc
JSTests/ChangeLog
JSTests/stress/proxy-class.js [new file with mode: 0644]