[CMake] Add minimum version information for tool dependencies