[GTK] Bump libsoup's minimum version to 2.42.0.