[GTK] Update apt dependency list
authorberto@igalia.com <berto@igalia.com@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Thu, 29 Aug 2013 12:35:00 +0000 (12:35 +0000)
committerberto@igalia.com <berto@igalia.com@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Thu, 29 Aug 2013 12:35:00 +0000 (12:35 +0000)
https://bugs.webkit.org/show_bug.cgi?id=120399

Reviewed by Philippe Normand.

Remove bogus package gail-3.0, add xfonts-utils (needed by
xorg-xserver) and switch to the latest versions of libtiff and
libjpeg.

* gtk/install-dependencies:

git-svn-id: https://svn.webkit.org/repository/webkit/trunk@154807 268f45cc-cd09-0410-ab3c-d52691b4dbfc

Tools/ChangeLog
Tools/gtk/install-dependencies

index 1ed9bf61ae5bafb9758c46c15a34f4ac19a508f4..1e781f9eea885cb9b23309437b6d54fcf31d8ec6 100644 (file)
@@ -1,3 +1,16 @@
+2013-08-29  Alberto Garcia  <berto@igalia.com>
+
+        [GTK] Update apt dependency list
+        https://bugs.webkit.org/show_bug.cgi?id=120399
+
+        Reviewed by Philippe Normand.
+
+        Remove bogus package gail-3.0, add xfonts-utils (needed by
+        xorg-xserver) and switch to the latest versions of libtiff and
+        libjpeg.
+
+        * gtk/install-dependencies:
+
 2013-08-28  Alexey Proskuryakov  <ap@apple.com>
 
         [WK2][Mac] WebKitTestRunner doesn't force system appearance
index 0913b0c4c72786dbf98e864445ecbf85cd8fb8e4..a887b748a164da875825026ac3937ada8304257f 100755 (executable)
@@ -41,7 +41,6 @@ function installDependenciesWithApt {
         autotools-dev \
         bison \
         flex \
-        gail-3.0 \
         gawk \
         gnome-common \
         gperf \
@@ -59,7 +58,7 @@ function installDependenciesWithApt {
         libgnutls-dev \
         libgudev-1.0-dev \
         libicu-dev \
-        libjpeg62-dev \
+        libjpeg8-dev \
         libmpg123-dev \
         libopus-dev \
         libpango1.0-dev \
@@ -75,7 +74,8 @@ function installDependenciesWithApt {
         libxslt1-dev \
         libxt-dev \
         libxtst-dev \
-        ruby
+        ruby \
+        xfonts-utils
 
     # These are dependencies necessary for running tests.
     apt-get install \
@@ -96,7 +96,7 @@ function installDependenciesWithApt {
         libgcrypt11-dev \
         libgpg-error-dev \
         libp11-kit-dev \
-        libtiff4-dev \
+        libtiff5-dev \
         libcroco3-dev \
         ragel \
         xutils-dev \