Reviewed by darin and ggaren.
authorap <ap@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Fri, 23 Jun 2006 04:37:59 +0000 (04:37 +0000)
committerap <ap@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Fri, 23 Jun 2006 04:37:59 +0000 (04:37 +0000)
        - see http://bugzilla.opendarwin.org/show_bug.cgi?id=9539
        Another case error preventing build

WebKitTools:
        * Scripts/webkitdirs.pm: Building WebKit now requires Xcode 2.3.

WebKitSite:
        * building/build.html: Ditto.

git-svn-id: https://svn.webkit.org/repository/webkit/trunk@14985 268f45cc-cd09-0410-ab3c-d52691b4dbfc

WebKitSite/ChangeLog
WebKitSite/building/build.html
WebKitTools/ChangeLog
WebKitTools/Scripts/webkitdirs.pm

index ee2a7d996728560ece1da218aa99d27a781954df..28de236aa378c2f6b1b06f7082ed959ccdbc81dd 100644 (file)
@@ -1,3 +1,12 @@
+2006-06-22  Alexey Proskuryakov  <ap@nypop.com>
+
+        Reviewed by Darin.
+
+        - see http://bugzilla.opendarwin.org/show_bug.cgi?id=9539
+        Another case error preventing build
+
+        * building/build.html: Building WebKit now requires Xcode 2.3.
+
 2006-06-21  Joost de Valk  <jdevalk@opendarwin.org>
 
         Reviewed and landed by Anders.
index 72ff72463d7dce9f0804f76d8a116674116835a5..1818b6555da40ccd68e9b498ac73c97e833677b5 100644 (file)
@@ -5,8 +5,7 @@
 
 <h2>Building WebKit</h2>
 
-<p>Before you build WebKit, you'll need to <a href="checkout.html">check out</a> sources. Next make sure that you have Xcode, preferably
-the latest version, which is 2.2.1 at this point. You will need at least Xcode 2.1 to be able to build WebKit.<p>
+<p>Before you build WebKit, you'll need to <a href="checkout.html">check out</a> sources. Next make sure that you have Xcode 2.3, which is the latest version at this point.<p>
 
 <ol>
 
index ccd620dff44689e0a182ce26f2818c233c0de754..0fc9df0fca51ac90e716a38f88224d4c3a2ca56e 100644 (file)
@@ -1,3 +1,12 @@
+2006-06-22  Alexey Proskuryakov  <ap@nypop.com>
+
+        Reviewed by ggaren.
+
+        - see http://bugzilla.opendarwin.org/show_bug.cgi?id=9539
+        Another case error preventing build
+
+        * Scripts/webkitdirs.pm: Building WebKit now requires Xcode 2.3.
+
 2006-06-22  Timothy Hatcher  <timothy@apple.com>
 
         Reviewed by Eric.
index a2191f4774eb2572740565ad9585b942ec267ac4..c1dc8af1351953014b694e7b60401f15c68273ac 100644 (file)
@@ -330,9 +330,9 @@ sub checkRequiredSystemConfig
             print "*************************************************************\n";
         }
         my $xcodeVersion = `xcodebuild -version`;
-        if ($xcodeVersion !~ /DevToolsCore-(\d+)/ || $1 < 620) {
+        if ($xcodeVersion !~ /DevToolsCore-(\d+)/ || $1 < 747) {
             print "*************************************************************\n";
-            print "Xcode Version 2.1 or later is required to build WebKit.\n";
+            print "Xcode Version 2.3 or later is required to build WebKit.\n";
             print "You have an earlier version of Xcode, thus the build will\n";
             print "most likely fail.  The latest Xcode is available from the web:\n";
             print "http://developer.apple.com/tools/xcode\n";