Make the GDB webkit.py script compatible with Python v3
authorzandobersek@gmail.com <zandobersek@gmail.com@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Sun, 15 Sep 2013 19:48:43 +0000 (19:48 +0000)
committerzandobersek@gmail.com <zandobersek@gmail.com@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Sun, 15 Sep 2013 19:48:43 +0000 (19:48 +0000)
commitfdcd768619a0cf7175c6a7d8410033fe5d173881
treecc4fff88be001ea701bf3313d0cf1f46e97d9fd0
parent685c444e52a796b56b92fd3388684fdc41b26843
Make the GDB webkit.py script compatible with Python v3
https://bugs.webkit.org/show_bug.cgi?id=121395

Reviewed by Ryosuke Niwa.

GDB fails to load the printing helpers from the webkit.py script if Python v3 is used. To avoid that,
uses of xrange() in the script are replaced with range(), and the print statements are changed into
the print() function invocations.

* gdb/webkit.py:
(guess_string_length):
(ustring_to_string):
(lstring_to_string):
(WTFCStringPrinter.to_string):
(PrintPathToRootCommand.invoke):

git-svn-id: https://svn.webkit.org/repository/webkit/trunk@155824 268f45cc-cd09-0410-ab3c-d52691b4dbfc
Tools/ChangeLog
Tools/gdb/webkit.py