Finally a real build fix.
[WebKit-https.git] / WebCore / WebCore.xcodeproj / project.pbxproj
index 667b0d9613a6a35b733105bccb07583e99c77dac..d216a2ab5900148c6754bd1d360595c2d04fc82d 100644 (file)
                0867D690FE84028FC02AAC07 /* Project object */ = {
                        isa = PBXProject;
                        buildConfigurationList = 149C284308902B11008A9EFC /* Build configuration list for PBXProject "WebCore" */;
-                       compatibilityVersion = "Xcode 2.4";
                        hasScannedForEncodings = 1;
                        knownRegions = (
                                English,
                        productRefGroup = 034768DFFF38A50411DB9C8B /* Products */;
                        projectDirPath = "";
                        projectRoot = "";
-                       shouldCheckCompatibility = 1;
                        targets = (
                                93F198A508245E59001E9ABC /* WebCore */,
                                DD041FBE09D9DDBE0010AF2A /* Derived Sources */,
                        baseConfigurationReference = 1CDD45E50BA9C84600F90147 /* WebCore.xcconfig */;
                        buildSettings = {
                                DEBUG_DEFINES = DISABLE_THREAD_CHECK;
+                               INSTALL_PATH = "$(BUILT_PRODUCTS_DIR)";
                                OTHER_LDFLAGS = (
+                                       "-lobjc",
                                        "-sub_library",
                                        libobjc,
                                );
                        baseConfigurationReference = 1CDD45E50BA9C84600F90147 /* WebCore.xcconfig */;
                        buildSettings = {
                                DEBUG_DEFINES = NDEBUG;
+                               INSTALL_PATH = "$(BUILT_PRODUCTS_DIR)";
                                OTHER_LDFLAGS = (
+                                       "-lobjc",
                                        "-sub_library",
                                        libobjc,
                                );
                        buildSettings = {
                                DEBUG_DEFINES = NDEBUG;
                                OTHER_LDFLAGS = (
+                                       "-lobjc",
                                        "-sub_library",
                                        libobjc,
                                        "-umbrella",