[GTK] Remove support for compiling with GStreamer 0.10
[WebKit-https.git] / Source / autotools / Versions.m4
1 m4_define([webkit_major_version], [1])
2 m4_define([webkit_minor_version], [11])
3 m4_define([webkit_micro_version], [5])
4
5 # This is the version we'll be using as part of our User-Agent string,
6 # e.g., AppleWebKit/$(webkit_user_agent_version) ...
7 #
8 # Sourced from Source/WebCore/Configurations/Version.xcconfig
9 m4_define([webkit_user_agent_major_version], [537])
10 m4_define([webkit_user_agent_minor_version], [30])
11
12 # Libtool library version, not to confuse with API version.
13 # See http://www.gnu.org/software/libtool/manual/html_node/Libtool-versioning.html
14 m4_define([libwebkitgtk_version], [18:1:18])
15 m4_define([libjavascriptcoregtk_version], [13:8:13])
16 m4_define([libwebkit2gtk_version], [21:0:21])
17
18 m4_define([gtk2_required_version], [2.10])
19 m4_define([gail2_required_version], [1.8])
20 m4_define([gtk3_required_version], [3.4.0])
21 m4_define([gail3_required_version], [3.0])
22
23 m4_define([cairo_required_version], [1.10])
24 m4_define([fontconfig_required_version], [2.4])
25 m4_define([freetype2_required_version], [9.0])
26 m4_define([glib_required_version], [2.32.0])
27 m4_define([libsoup_required_version], [2.40.0])
28 m4_define([libxml_required_version], [2.6])
29 m4_define([pango_required_version], [1.21.0])
30
31 m4_define([gstreamer_required_version], [1.0.3])
32 m4_define([gstreamer_plugins_base_required_version], [1.0.3])
33
34 m4_define([gobject_introspection_required], [0.9.5])