[GTK] Limit the supported compilers to GCC >= 4.7 and Clang >= 3.0
[WebKit-https.git] / Source / autotools / SetupCompilerFlags.m4
1 # Use C99 as the language standard for C code.
2 CFLAGS="$CFLAGS -std=c99"
3 # Do not warn about C++11 incompatibilities and extensions.
4 CXXFLAGS="$CXXFLAGS -Wno-c++11-compat -Wno-c++11-extensions"
5
6 # Clang requires suppression of unused arguments warning.
7 if test "$CC" = "clang"; then
8     CFLAGS="$CFLAGS -Qunused-arguments"
9 fi
10 # libstdc++ is at the moment the only option as the C++ standard library.
11 if test "$CXX" = "clang++"; then
12     CXXFLAGS="$CXXFLAGS -stdlib=libstdc++ -Qunused-arguments"
13 fi
14
15 if test "$host_cpu" = "sh4"; then
16     CXXFLAGS="$CXXFLAGS -mieee -w"
17     CFLAGS="$CFLAGS -mieee -w"
18 fi
19
20 # Add '-g' flag to gcc to build with debug symbols.
21 if test "$enable_debug_symbols" = "min"; then
22     CXXFLAGS="$CXXFLAGS -g1"
23     CFLAGS="$CFLAGS -g1"
24 elif test "$enable_debug_symbols" != "no"; then
25     CXXFLAGS="$CXXFLAGS -g"
26     CFLAGS="$CFLAGS -g"
27 fi
28
29 # Add the appropriate 'O' level for optimized builds.
30 if test "$enable_optimizations" = "yes"; then
31     CXXFLAGS="$CXXFLAGS -O2"
32     CFLAGS="$CFLAGS -O2"
33 else
34     CXXFLAGS="$CXXFLAGS -O0"
35     CFLAGS="$CFLAGS -O0"
36 fi