[GTK] Limit the supported compilers to GCC >= 4.7 and Clang >= 3.0
[WebKit-https.git] / Source / autotools / CheckSystemAndBasicDependencies.m4
1 AC_CANONICAL_HOST
2 AC_MSG_CHECKING([for native Win32])
3 case "$host" in
4      *-*-mingw*)
5        os_win32=yes
6        ;;
7      *)
8        os_win32=no
9        ;;
10 esac
11 AC_MSG_RESULT([$os_win32])
12
13 case "$host" in
14      *-*-linux*)
15        os_linux=yes
16        ;;
17      *-*-freebsd*)
18        os_freebsd=yes
19        ;;
20      *-*-darwin*)
21        os_darwin=yes
22        ;;
23 esac
24
25 case "$host_os" in
26      gnu* | linux* | k*bsd*-gnu)
27        os_gnu=yes
28        ;;
29      *)
30        os_gnu=no
31        ;;
32 esac
33
34 AC_PATH_PROG(PERL, perl)
35 if test -z "$PERL"; then
36     AC_MSG_ERROR([You need 'perl' to compile WebKit])
37 fi
38
39 AC_PATH_PROG(PYTHON, python)
40 if test -z "$PYTHON"; then
41     AC_MSG_ERROR([You need 'python' to compile WebKit])
42 fi
43
44 AC_PATH_PROG(RUBY, ruby)
45 if test -z "$RUBY"; then
46     AC_MSG_ERROR([You need 'ruby' to compile WebKit])
47 fi
48
49 AC_PATH_PROG(BISON, bison)
50 if test -z "$BISON"; then
51     AC_MSG_ERROR([You need the 'bison' parser generator to compile WebKit])
52 fi
53
54 AC_PATH_PROG(MV, mv)
55 if test -z "$MV"; then
56     AC_MSG_ERROR([You need 'mv' to compile WebKit])
57 fi
58
59 AC_PATH_PROG(GPERF, gperf)
60 if test -z "$GPERF"; then
61     AC_MSG_ERROR([You need the 'gperf' hash function generator to compile WebKit])
62 fi
63
64 AC_PATH_PROG(FLEX, flex)
65 if test -z "$FLEX"; then
66     AC_MSG_ERROR([You need the 'flex' lexer generator to compile WebKit])
67 else
68     FLEX_VERSION=`$FLEX --version | sed 's,.*\ \([0-9]*\.[0-9]*\.[0-9]*\)$,\1,'`
69     AX_COMPARE_VERSION([2.5.33],[gt],[$FLEX_VERSION],
70         AC_MSG_WARN([You need at least version 2.5.33 of the 'flex' lexer generator to compile WebKit correctly]))
71 fi
72
73 # If CFLAGS and CXXFLAGS are unset, default to empty.
74 # This is to tell automake not to include '-g' if C{XX,}FLAGS is not set.
75 # For more info - http://www.gnu.org/software/automake/manual/autoconf.html#C_002b_002b-Compiler
76 if test -z "$CXXFLAGS"; then
77     CXXFLAGS=""
78 fi
79 if test -z "$CFLAGS"; then
80     CFLAGS=""
81 fi
82
83 AC_PROG_CC
84 AC_PROG_CXX
85 AC_PROG_INSTALL
86 AC_SYS_LARGEFILE
87
88 # Check that an appropriate C compiler is available.
89 AC_LANG_PUSH([C])
90 AC_COMPILE_IFELSE([AC_LANG_PROGRAM([
91 #if !(defined(__GNUC__) && !defined(__clang__) && !defined(__INTEL_COMPILER) && __GNUC__ >= 4 && __GNUC_MINOR__ >= 7) \
92     && !(defined(__clang__) && __clang_major__ >= 3 && __clang_minor__ >= 0)
93 #error Unsupported compiler
94 #endif
95 ],[])],[],[AC_MSG_ERROR([Compiler GCC >= 4.7 or Clang >= 3.0 is required for C compilation])])
96 AC_LANG_POP([C])
97
98 # Check that an appropriate C++ compiler is available.
99 AC_LANG_PUSH([C++])
100 AC_COMPILE_IFELSE([AC_LANG_PROGRAM([
101 #if !(defined(__GNUG__) && defined(__GNUC__) && !defined(__clang__) && !defined(__INTEL_COMPILER) && __GNUC__ >= 4 && __GNUC_MINOR__ >= 7) \
102     && !(defined(__clang__) && __clang_major__ >= 3 && __clang_minor__ >= 0)
103 #error Unsupported compiler
104 #endif
105 ],[])],[],[AC_MSG_ERROR([Compiler GCC >= 4.7 or Clang >= 3.0 is required for C++ compilation])])
106 AC_LANG_POP([C++])
107
108 # C/C++ Language Features
109 AC_C_CONST
110 AC_C_INLINE
111 AC_C_VOLATILE
112
113 # C/C++ Headers
114 AC_HEADER_STDC
115 AC_HEADER_STDBOOL