[GTK] Be able to disable gtk2 dependency