Update label for blacklisted plug-in