[Cocoa] Remove deprecated _WKVisitedLinkProvider declarations that aren’t needed