[CMake] Minimum python version should be 2.7.