Unreviewed, manual rollout of r228866 causing EGL_BAD_CONTEXT errors