[CMake] Bump the minimum required version