Use is<>() / downcast<>() for Element
[WebKit-https.git] / Source / WebKit2 / WebProcess / InjectedBundle / DOM / InjectedBundleNodeHandle.cpp
2014-09-30 cdumez@apple.comUse is<>() / downcast<>() for Element
2014-09-25 cdumez@apple.comUse is<HTML*Element>() instead of isHTML*Element()...
2014-09-24 cdumez@apple.comUse is<HTML*Element>() instead of isHTML*Element()...
2014-09-23 cdumez@apple.comUse downcast<HTML*Element>() instead of toHTML*Element()
2014-09-22 cdumez@apple.comGenerate Element casting helper functions
2014-08-28 zalan@apple.comSubpixel layout: Rename LayoutRect's device pixel snapp...
2014-08-19 commit-queue@webki... Expose injected bundle SPI to get a node's URL element...
2014-08-19 commit-queue@webki... Extend injected bundle node snapshotting to support...
2014-04-08 mitz@apple.com[Cocoa] Add a way to tell whether a WKWebProcessPlugInN...
2014-03-25 andersca@apple.comAdd a WebFrame::fromCoreFrame static member function...
2013-12-24 weinig@apple.com[WK2] Replace usage of DEFINE_STATIC_LOCAL with NeverDe...
2013-10-01 andersca@apple.comGet rid of more uses of OwnPtr and PassOwnPtr
2013-09-13 andersca@apple.comUse nullptr instead of 0 in calls to HashMap::add
2013-08-30 akling@apple.comNode::document() should return a reference.
2013-08-16 akling@apple.com<https://webkit.org/b/119893> FrameView::frame() should...
2013-08-15 andersca@apple.com<https://webkit.org/b/119859> Frame::loader() should...
2013-07-30 timothy_horton@app... Fix typo in enum name ("SelectionInSnaphot" -> "Selecti...
2013-07-16 kangil.han@samsung.comIntroduce toHTMLIFrameElement
2013-07-01 kangil.han@samsung.comAdopt toHTMLTextAreaElement for code cleanup
2013-06-28 kangil.han@samsung.comAdopt is/toHTMLInputElement for code cleanup
2013-05-17 beidson@apple.comReplace WebFrameLoaderClient static_casts with a functi...
2013-04-11 timothy_horton@app... InjectedBundleNodeHandle::imageForRect doesn't respect...
2013-03-19 weinig@apple.comNeed a bundle SPI to generate a snapshot of a specific...
2013-03-14 inferno@chromium.orgReplace static_casts with to* helper functions.
2013-03-03 abarth@webkit.orgUnreviewed attempted build fix. Adds back some includes...
2013-03-03 abarth@webkit.orgUnreviewed rollout of trac.webkit.org/r144530
2013-03-02 ap@apple.com Reduce amount of rebuilding when touching netwo...
2013-03-01 commit-queue@webki... Unreviewed, rolling out r144422 and r144424.
2013-03-01 ap@apple.comReduce amount of rebuilding when touching networking...
2012-10-07 benjamin@webkit.orgRename first/second to key/value in HashMap iterators
2012-08-28 commit-queue@webki... Unreviewed, rolling out r126914.
2012-08-28 caio.oliveira@open... Rename first/second to key/value in HashMap iterators
2012-08-28 tkent@chromium.orgUnreviewed, rolling out r126836.
2012-08-28 caio.oliveira@open... Rename first/second to key/value in HashMap iterators
2012-03-31 eae@chromium.orgChange WebKit/WebKit2 platform code to use pixel snappe...
2012-03-29 caio.oliveira@open... HashMap<>::add should return a more descriptive object
2011-11-09 andersca@apple.comElement::boundsInWindowSpace should be Element::boundsI...
2011-06-24 dominicc@chromium.org2011-06-24 Dominic Cooney <dominicc@chromium.org>
2011-05-06 philn@webkit.orgTools:
2011-05-03 commit-queue@webki... 2011-05-03 Julien Chaffraix <jchaffraix@codeaurora...
2011-04-21 commit-queue@webki... 2011-04-20 Dominic Cooney <dominicc@chromium.org>
2011-04-01 weinig@apple.com2011-04-01 Sam Weinig <sam@webkit.org>
2011-03-16 weinig@apple.comAdd WebKit2 API to figure out if an input or textarea...
2011-02-24 mthole@apple.comWK2: Add ability to get document node for a WKBundleNod...
2011-01-28 laszlo.1.gombos... 2011-01-27 Greg Coletta <greg.coletta@nokia.com>
2011-01-20 kdecker@apple.com Reviewed by Anders Carlsson.
2011-01-15 abarth@webkit.orgMove WebKit2 into Source