Add WTF::move()
[WebKit-https.git] / Source / WebCore / workers / WorkerGlobalScope.cpp
2014-07-03 dbates@webkit.orgAdd WTF::move()
2014-06-19 zandobersek@gmail.comScriptExecutionContext::Task, FileThread::Task paramete...
2014-06-18 zandobersek@gmail.comScriptExecutionContext::Task parameters should always...
2014-06-16 zandobersek@gmail.comHave ScriptExecutionContext::Task functions take in...
2014-05-11 zandobersek@gmail.comMove Source/WebCore/workers/ code to std::unique_ptr
2014-05-10 commit-queue@webki... Unreviewed, rolling out r168578.
2014-05-10 zandobersek@gmail.comMove Source/WebCore/workers/ code to std::unique_ptr
2014-05-06 commit-queue@webki... Removed unnecessary notImplemented.h includes.
2014-04-29 zandobersek@gmail.comScriptExecutionContext::Task should work well with...
2014-04-28 commit-queue@webki... Unreviewed, rolling out r167855.
2014-04-27 zandobersek@gmail.comScriptExecutionContext::Task should work well with...
2014-04-21 zandobersek@gmail.comMove cross-port Source/WebCore/page/ code to std::uniqu...
2014-04-21 darin@apple.comScriptExecutionContext::stopActiveDOMObjects iterates...
2014-03-15 mjs@apple.com.: Replace "Apple Computer, Inc." with "Apple Inc....
2014-02-16 akling@apple.comAdd checked casts for ScriptExecutionContext.
2014-02-15 akling@apple.comCTTE: WorkerGlobalScope is always owned by a WorkerThread.
2014-02-11 ap@apple.comAdd hooks for wrapping CryptoKeys in SerializedScriptValue
2014-02-06 joepeck@webkit.orgWeb Inspector: Add Console support to JSContext Inspection
2014-01-18 bburg@apple.comWeb Inspector: Page should use std::unique_ptr for...
2014-01-10 benjamin@webkit.orgRemove the BlackBerry port from trunk
2013-12-11 joepeck@webkit.orgWeb Inspector: Push More Inspector Required Classes...
2013-11-22 commit-queue@webki... Remove ENABLE_WORKERS
2013-10-08 commit-queue@webki... Unreviewed, rolling out r157061.
2013-10-07 andersca@apple.comClean up ScriptExecutionContext::Task and subclasses
2013-10-02 weinig@apple.comConvert PageGroup to using std::unique_ptr
2013-09-27 darin@apple.comrename KURL to URL
2013-09-25 akling@apple.comReduce repetitive EventTarget subclassing.
2013-09-14 weinig@apple.comReplace ScriptState with JSC::ExecState
2013-09-09 darin@apple.comTighten up EventQueue classes a bit, less indirection...
2013-09-08 akling@apple.comScriptExecutionContext: Use FINAL instead of foo()...
2013-08-11 akling@apple.comMake some things that return never-null pointers return...
2013-06-27 ch.dumez@sisa.sams... Rename WorkerContext to WorkerGlobalScope