Replace WTF::move with WTFMove
[WebKit-https.git] / Source / WebCore / rendering / RenderListItem.cpp
2016-01-02 aestes@apple.comReplace WTF::move with WTFMove
2015-08-12 zalan@apple.comDisconnect LayoutStateDisabler logic and RenderView...
2015-02-14 cdumez@apple.comRenderListItem resets its marker's style on style chang...
2015-01-26 cdumez@apple.comFirst argument to DOM traversal functions should be...
2014-12-14 akling@apple.comReplace PassRef with Ref/Ref&& across the board.
2014-11-12 cdumez@apple.comMinor improvements to RenderListItem
2014-11-04 akling@apple.comClarify RenderListMarker ownership model.
2014-10-16 cdumez@apple.comUse is<>() / downcast<>() for list-related render objects
2014-10-08 cdumez@apple.comUse is<>() / downcast<>() for RenderBlock objects
2014-09-28 cdumez@apple.comUse the new is<>() / downcast<>() for more Node subclasses
2014-09-23 cdumez@apple.comUse downcast<HTML*Element>() instead of toHTML*Element()
2014-08-01 commit-queue@webki... ASSERTION FAILED: listNode in WebCore::RenderListItem...
2014-07-03 dbates@webkit.orgAdd WTF::move()
2014-03-21 hyatt@apple.comCrash in RenderBlock::addChildIgnoringAnonymousColumnBl...
2013-12-31 akling@apple.comRenderListItem should store its marker in a RenderPtr.
2013-11-24 gyuyoung.kim@samsu... Generate toHTMLMarquee|OListElement() to cleanup static...
2013-11-21 stavila@adobe.com[CSS Regions] Implement visual overflow for first ...
2013-11-15 commit-queue@webki... Unreviewed, rolling out r159337.
2013-11-15 stavila@adobe.com[CSS Regions] Implement visual overflow for first ...
2013-11-10 andersca@apple.comRemove all 'std' using directives from WebCore
2013-11-08 akling@apple.comInlineFlowBox always has a RenderBoxModelObject, take...
2013-11-07 akling@apple.comUse tighter InlineBox subtypes in some places.
2013-10-29 akling@apple.comRenderElement::style() should return a reference.
2013-10-27 akling@apple.comRenderers should receive their style at construction.
2013-10-19 weinig@apple.comMove m_lineBoxes from RenderBlock to RenderBlockFlow...
2013-10-19 akling@apple.comStart passing RenderStyle around with PassRef.
2013-10-17 mihnea@adobe.com[CSS Regions] Anonymous nested regions
2013-10-16 akling@apple.comTake RenderObjects out of the arena.
2013-10-14 akling@apple.comPass Document directly to anonymous renderer constructors.
2013-09-23 antti@apple.comRename RenderObject::first/lastChild to RenderObject...
2013-09-20 akling@apple.comOptimize fetching the Node for never-anonymous renderers.
2013-09-20 antti@apple.comMake RenderObject::parent() return RenderElement
2013-09-13 akling@apple.com[CTTE] RenderListItem is never anonymous.
2013-09-13 akling@apple.com[CTTE] RenderListMarker is always anonymous and owned...
2013-09-09 antti@apple.comHide node() below RenderLayerModelObject, use element...
2013-09-09 akling@apple.comInlineBox::root() should return a reference.
2013-09-06 hyatt@apple.comAdd new RenderBlockFlow class.
2013-09-06 bdakin@apple.comReverting revisions 155139, 155141, 155142, and 155145...
2013-09-05 hyatt@apple.comMake RenderListItem inherit from RenderBlockFlow.
2013-08-25 akling@apple.comRenderObject::document() should return a reference.
2013-08-24 akling@apple.comRenderObject::view() should return a reference.
2013-08-23 zalan@apple.comMathML: ASSERTION FAILED: !isPreferredLogicalHeightDirt...
2013-08-17 antti@apple.com<https://webkit.org/b/119886> PseudoElement is abusing...
2013-08-12 antti@apple.comMove ElementTraversal to ElementTraversal.h
2013-06-04 kangil.han@samsung.comRemove unused arithmetic operation in RenderListItem
2013-04-30 abucur@adobe.comCleanup HTMLOListElement<->RenderListItem bridge
2013-04-22 abucur@adobe.comUse DOM ordering for list counts
2013-04-16 andersca@apple.comRemove unneeded headers from ScriptExecutionContext.h
2013-04-12 rniwa@webkit.orgUnreviewed, rolling out r147942, r148026, and r148092.
2013-04-11 ap@apple.com Remove some includes of CachedImage.h
2013-04-09 abucur@adobe.comUse DOM ordering for list counts
2013-03-26 commit-queue@webki... Unreviewed, rolling out r146879.
2013-03-26 abucur@adobe.comUse DOM ordering for list counts
2013-03-03 abarth@webkit.orgUnreviewed rollout of trac.webkit.org/r144530
2013-03-02 ap@apple.com Reduce amount of rebuilding when touching netwo...
2013-03-01 commit-queue@webki... Unreviewed, rolling out r144422 and r144424.
2013-03-01 benjamin@webkit.orgGet rid of two silly static null Strings
2013-03-01 ap@apple.comReduce amount of rebuilding when touching networking...
2013-01-19 antti@apple.comMake renderer constructors take Element where possible
2013-01-17 commit-queue@webki... Unreviewed, rolling out r140023.
2013-01-17 antti@apple.comMake renderer constructors take Element where possible
2013-01-16 antti@apple.comTighten RenderLayerModelObject subclass constructors...
2013-01-16 ojan@chromium.orgRenderListMarker::computePreferredLogicalWidth should...
2013-01-15 ojan@chromium.orgRenderListItem does not need to override computePreferr...
2012-12-11 dpranke@chromium.orgSwitch to new PseudoElement based :before and :after
2012-10-19 mark.lam@apple.comAdded WTF::StackStats mechanism.
2012-10-11 pfeldman@chromium.orgNot reviewed: revert 131004, 131012, 131016, 131042...
2012-10-11 commit-queue@webki... Move :before and :after into the DOM
2012-08-22 commit-queue@webki... Reduce Font.h includes across project -- improves Rende...
2012-08-20 jchaffraix@webkit.orgIntroduce a will-be-removed-from-tree notification...
2012-08-18 commit-queue@webki... Unreviewed, rolling out r125940.
2012-08-17 jchaffraix@webkit.orgIntroduce a will-be-removed-from-tree notification...
2012-08-16 jchaffraix@webkit.orgAdd a was-inserted-into-tree notification to RenderObject
2012-06-25 simon.fraser@apple.comRename isPositioned to isOutOfFlowPositioned for clarity
2012-03-22 robert@webkit.orgText should overflow when list item height set to 0
2012-02-29 commit-queue@webki... Crash when changing list marker locations
2012-02-22 commit-queue@webki... Crash from empty anonymous block preceding :before...
2011-12-16 jwieczorek@webkit.orgAdd support for <ol reversed>.
2011-12-16 commit-queue@webki... Unreviewed, rolling out r103062.
2011-12-16 alexis.menard@open... Add support for <ol reversed>.
2011-09-07 commit-queue@webki... Replace usages of Vector<UChar> with existing StringBuilder
2011-07-11 leviw@chromium.org2011-07-11 Levi Weintraub <leviw@chromium.org>
2011-07-09 simon.fraser@apple.com2011-07-08 Simon Fraser <simon.fraser@apple.com>
2011-06-29 leviw@chromium.org2011-06-29 Levi Weintraub <leviw@chromium.org>
2011-06-07 leviw@chromium.org2011-06-07 Levi Weintraub <leviw@chromium.org>
2011-06-03 leviw@chromium.org2011-06-02 Levi Weintraub <leviw@chromium.org>
2011-05-25 leviw@chromium.org2011-05-25 Levi Weintraub <leviw@chromium.org>
2011-05-25 yuzo@google.com2011-05-25 Yuzo Fujishima <yuzo@google.com>
2011-03-31 hyatt@apple.comhttps://bugs.webkit.org/show_bug.cgi?id=57565
2011-02-01 hyatt@apple.comhttps://bugs.webkit.org/show_bug.cgi?id=53520
2011-01-08 abarth@webkit.orgMove WebCore into Source