[WTF] Add makeUnique<T>, which ensures T is fast-allocated, makeUnique / makeUniqueWi...
[WebKit-https.git] / Source / WebCore / page / PageGroup.cpp
2019-08-19 ysuzuki@apple.com[WTF] Add makeUnique<T>, which ensures T is fast-alloca...
2019-07-09 cdumez@apple.comCleanup uses of NetworkProcess::m_sessionByConnection
2018-04-03 cdumez@apple.comDrop MainFrame class
2018-02-07 don.olmstead@sony.comRemove WebCore/ForwardingHeaders directory
2017-10-19 dbates@webkit.orgUse "= default" to denote default constructor or destructor
2017-01-17 commit-queue@webki... Remove unnecessary includes
2016-10-29 commit-queue@webki... Remove some unnecessary includes
2016-09-06 fpizlo@apple.comButterflies should be allocated in Auxiliary MarkedSpac...
2016-08-24 fpizlo@apple.comUnreviewed, roll out r204901, r204897, r204866, r204856...
2016-08-23 fpizlo@apple.comButterflies should be allocated in Auxiliary MarkedSpac...
2016-02-04 eric.carlson@apple.comPageGroup::captionPreferences should return a reference
2015-09-23 antti@apple.comSplit author style code out from DocumentStyleSheetColl...
2015-08-13 bfulgham@apple.com[Win] More build fixes.
2015-06-05 commit-queue@webki... Replace 0 with nullptr in WebCore/Page.
2015-06-03 commit-queue@webki... Use modern for-loops in WebCore/page.
2015-01-30 cdumez@apple.comRename shared() static member functions to singleton...
2015-01-28 cdumez@apple.comRename pageCache() to PageCache::shared() and return...
2015-01-02 commit-queue@webki... Remove GroupSettings
2014-12-29 andersca@apple.comRemove more dead code
2014-12-29 andersca@apple.comGet rid of some PageGroup storage functions
2014-12-11 andersca@apple.comGet rid of the storage strategy
2014-12-02 andersca@apple.comRemove visited link handling from PageGroup
2014-11-25 andersca@apple.comRemove user content handling from PageGroup
2014-07-03 dbates@webkit.orgAdd WTF::move()
2014-05-17 andersca@apple.comExpose WKUserScript as API
2014-02-26 andersca@apple.comRename WebCore::VisitedLinkProvider to WebCore::Visited...
2014-02-25 andersca@apple.comSimplify visited link style invalidation
2014-02-25 andersca@apple.comAdd a DefaultVisitedLinkProvider and route visited...
2014-02-19 mitz@apple.comSimplify PLATFORM(MAC) && !PLATFORM(IOS) and similar...
2014-01-30 commit-queue@webki... Unreviewed, rolling out r163048.
2014-01-30 weinig@apple.comCaptionUserPreferences should not be on the PageGroup...
2014-01-28 andersca@apple.comAdd stubbed out VisitedLinkProvider class
2014-01-21 andersca@apple.comRemove an unused PageGroup function
2014-01-21 andersca@apple.comMove user style sheet handling to UserContentController
2014-01-21 andersca@apple.comUserContentController should keep track of user scripts
2014-01-20 andersca@apple.comGive each page a UserContentController
2013-12-27 dbates@webkit.org[iOS] Upstream WebCore/page changes
2013-10-02 weinig@apple.comCTTE: DOMWrapperWorlds should be passed around by reference
2013-10-02 weinig@apple.comConvert PageGroup to using std::unique_ptr
2013-09-30 weinig@apple.comConvert a bunch of OwnPtrs on Page to std::unique_ptrs
2013-09-27 darin@apple.comrename KURL to URL
2013-09-27 darin@apple.comAdd empty MainFrame class
2013-09-25 benjamin@webkit.orgTie the life of DocumentStyleSheetCollection and Docume...
2013-09-18 andersca@apple.comRefPtrHashMap should work with move only types
2013-09-13 andersca@apple.comUse nullptr instead of 0 in calls to HashMap::add
2013-09-03 darin@apple.comCut down on double hashing and code needlessly using...
2013-08-27 akling@apple.comPage::mainFrame() should return a reference.
2013-08-25 darin@apple.comFrame::tree should return a reference instead of a...
2013-08-19 akling@apple.com<https://webkit.org/b/120000> Chrome::client() should...
2013-08-07 antti@apple.com2.5% regression on page cycler moz
2013-06-26 bfulgham@apple.comPrepare CaptionUserPreferencesMac for use on Windows...
2013-05-17 akling@apple.comPage::chrome() should return a reference.
2013-05-09 andersca@apple.comAdd a StorageStrategy hook for creating transient local...
2013-05-07 mikhail.pozdnyakov... HashTraits<RefPtr<P> >::PeekType should be raw pointer...
2013-04-29 jpfau@apple.comChange approach to third-party blocking for LocalStorage
2013-04-18 andersca@apple.comChange storage factory functions to take a PageGroup...
2013-04-14 weinig@apple.comMake Frame's ScriptController an OwnPtr and remove...
2013-04-05 rniwa@webkit.orgRemove Chromium code from WebCore/page
2013-03-14 jer.noble@apple.comCrash in DumpRenderTree at com.apple.WebCore: WebCore...
2013-02-28 eric.carlson@apple.comRefine Ryosuke's r144367 fix.
2013-02-28 rniwa@webkit.orgRevert an erroneous change in r144336.
2013-02-28 eric.carlson@apple.com[Mac] use HAVE() macro instead of version check
2013-02-20 eric.carlson@apple.comiOS does not use CaptionUserPreferencesMac
2013-02-12 eric.carlson@apple.com[Mac] Track language selection should be sticky
2013-02-05 dino@apple.com[Mac] Captions menu should indicate language and type...
2013-02-04 eric.carlson@apple.comUpdate CaptionUserPreferences
2012-12-02 commit-queue@webki... Need a method to close all idle localstorage databases...
2012-11-18 antti@apple.comREGRESSION(r129644): User StyleSheet not applying
2012-11-16 dglazkov@chromium.orgUnreviewed, rolling out r134986.
2012-11-16 antti@apple.comREGRESSION(r129644): User StyleSheet not applying
2012-10-24 eric.carlson@apple.comAllow ports to override text track rendering style
2012-10-19 msaboff@apple.comAdd String version of visitedLinkHash() to properly...
2012-10-14 weinig@apple.comMake UserScript and UserStyleSheet value objects that...
2012-10-07 benjamin@webkit.orgRename first/second to key/value in HashMap iterators
2012-09-24 antti@apple.comSplit stylesheet related code out from Document
2012-08-28 commit-queue@webki... Unreviewed, rolling out r126914.
2012-08-28 caio.oliveira@open... Rename first/second to key/value in HashMap iterators
2012-08-28 tkent@chromium.orgUnreviewed, rolling out r126836.
2012-08-28 caio.oliveira@open... Rename first/second to key/value in HashMap iterators
2012-05-12 pilgrim@chromium.org[Chromium] Call isLinkVisited directly
2012-03-29 caio.oliveira@open... HashMap<>::add should return a more descriptive object
2012-03-02 abarth@webkit.orgMove WebCore/storage/IDB* files into WebCore/Modules...
2012-03-02 abarth@webkit.orgRemove last ENABLED(INDEXED_DATABASE) ifdef from WebCor...
2011-12-29 caio.oliveira@open... Use HashMap<OwnPtr> for UserScriptMap and UserStyleSheetMap
2011-12-21 commit-queue@webki... Change adoptPtr(new ...) to ...::create in Page.cpp
2011-10-16 abarth@webkit.orgAlways enable ENABLE(DOM_STORAGE)
2011-09-01 abarth@webkit.org[Chromium] Rename PlatformBridge to PlatformSupport
2011-04-25 abarth@webkit.org2011-04-25 Adam Barth <abarth@webkit.org>
2011-04-16 weinig@apple.com2011-04-16 Sam Weinig <sam@webkit.org>
2011-03-11 beidson@apple.comReviewed and landed by Brady Eidson.
2011-01-21 commit-queue@webki... 2011-01-21 Adam Klein <adamk@chromium.org>
2011-01-20 dimich@chromium.org2011-01-19 Sheriff Bot <webkit.review.bot@gmail.com>
2011-01-20 commit-queue@webki... 2011-01-19 Adam Klein <adamk@chromium.org>
2011-01-08 abarth@webkit.orgMove WebCore into Source