Use "= default" to denote default constructor or destructor
[WebKit-https.git] / Source / WebCore / editing / EditCommand.cpp
2017-10-19 dbates@webkit.orgUse "= default" to denote default constructor or destructor
2017-08-25 wenson_hsieh@apple.comUsing the touchbar, both align left and align justify...
2017-08-18 wenson_hsieh@apple.com[Input Events] Rename inputType "formatForeColor" to...
2017-03-03 commit-queue@webki... Rename htmlediting.h/cpp to Editing.h/cpp
2017-01-17 commit-queue@webki... Remove unnecessary includes
2016-12-19 wenson_hsieh@apple.comChanging text direction fires input events with null...
2016-10-27 wenson_hsieh@apple.comSupport "insertFromDrop" and "deleteByDrag" for the...
2016-10-21 wenson_hsieh@apple.comSupport (insertFrom|deleteBy)Composition and (insert...
2016-10-21 wenson_hsieh@apple.comImplement InputEvent.getTargetRanges() for the input...
2016-10-12 wenson_hsieh@apple.comAdd experimental support for the "formatForeColor"...
2016-10-10 wenson_hsieh@apple.comSupport InputEvent.data for the new InputEvent spec
2016-10-10 wenson_hsieh@apple.comSupport InputEvent.inputType for the new InputEvent...
2016-05-14 darin@apple.comCTTE for the HTML editing header
2016-04-04 d_russell@apple.comAX: new lines in content editable elements don't notify...
2015-10-28 hs85.jeong@samsung.comReplace 0 and NULL with nullptr in WebCore/editing.
2015-05-01 jdiggs@igalia.com[GTK] REGRESSION(183368): It made editing tests assert
2015-04-26 commit-queue@webki... AX: richer text change notifications (142719)
2015-04-24 commit-queue@webki... Unreviewed, rolling out r183266.
2015-04-24 commit-queue@webki... AX: richer text change notifications (142719)
2015-01-26 cdumez@apple.comFirst argument to DOM traversal functions should be...
2014-11-06 mitz@apple.comRemove the unused deletion UI feature
2014-03-15 mjs@apple.com.: Replace "Apple Computer, Inc." with "Apple Inc....
2013-10-31 commit-queue@webki... [webcore/editing] remove extra header includes from...
2013-10-08 akling@apple.comCTTE: EditCommand always has a Document.
2013-09-01 akling@apple.comGive EditCommand a protected Frame& getter.
2013-09-01 akling@apple.comEditCommand constructors should take Document&.
2013-08-19 psolanki@apple.com<https://webkit.org/b/119918> Frame::selection() should...
2013-05-15 andersca@apple.comFrame::editor() should return a reference
2013-02-13 rniwa@webkit.orgTurn avoidIntersectionWithNode into Editor member funct...
2013-02-11 enrica@apple.comSource/WebCore: Add ENABLE_DELETION_UI to control the...
2012-12-11 antti@apple.comFactor node traversal into standalone functions
2011-12-16 rniwa@webkit.orgOnly EditCommandComposition should implement unapply...
2011-12-14 rniwa@webkit.orgPush more member functions from EditCommand to Composit...
2011-12-13 rniwa@webkit.orgREGRESSION(r102357): respondToUnappliedEditing exits...
2011-12-12 rniwa@webkit.orgWebKit code shouldn't be calling applyCommand directly
2011-12-10 rniwa@webkit.orgThere should be a way to count the number of nodes...
2011-12-08 rniwa@webkit.orgCompositeEditCommand should not be kept alive for undo...
2011-07-13 rniwa@webkit.orgDon't reuse the last InsertTextCommand
2011-05-05 rniwa@webkit.org2011-05-05 Ryosuke Niwa <rniwa@webkit.org>
2011-04-20 commit-queue@webki... 2011-04-20 Jia Pu <jpu@apple.com>
2011-03-01 commit-queue@webki... 2011-03-01 Jia Pu <jpu@apple.com>
2011-01-08 abarth@webkit.orgMove WebCore into Source