Replace WTF::move with WTFMove
[WebKit-https.git] / Source / WebCore / dom / ChildListMutationScope.cpp
2016-01-02 aestes@apple.comReplace WTF::move with WTFMove
2015-12-04 gyuyoung.kim@webki... Reduce uses of PassRefPtr in DOM - 1
2015-11-03 hs85.jeong@samsung.comReplace 0 and NULL with nullptr in WebCore/dom.
2014-11-04 cdumez@apple.comAdd ptr() method to Ref class
2014-11-04 cdumez@apple.comAllow implicit conversion from Ref<T> to T&
2014-07-03 dbates@webkit.orgAdd WTF::move()
2014-03-14 svillar@igalia.comRename DEFINE_STATIC_LOCAL to DEPRECATED_DEFINE_STATIC_...
2014-02-09 zandobersek@gmail.comManage MutationObserverInterestGroup through std::uniqu...
2013-11-04 commit-queue@webki... [webcore/dom] Remove extra header includes from cpp...
2013-09-23 weinig@apple.comCTTE: Use references more in ContainerNode, ContainerNo...
2013-09-13 andersca@apple.comUse nullptr instead of 0 in calls to HashMap::add
2013-01-04 adamk@chromium.orgRemove ENABLE_MUTATION_OBSERVERS #define
2012-10-07 benjamin@webkit.orgRename first/second to key/value in HashMap iterators
2012-09-22 adamk@chromium.orgRemove bogus assertions from ChildListMutationScope
2012-09-22 adamk@chromium.orgSimplify and optimize ChildListMutationScope
2012-08-28 commit-queue@webki... Unreviewed, rolling out r126914.
2012-08-28 caio.oliveira@open... Rename first/second to key/value in HashMap iterators
2012-08-28 tkent@chromium.orgUnreviewed, rolling out r126836.
2012-08-28 caio.oliveira@open... Rename first/second to key/value in HashMap iterators
2012-04-06 commit-queue@webki... Unreviewed, rolling out r113267.
2012-04-06 adamk@chromium.orgRemove bogus assert from ChildListMutationScope
2012-04-05 adamk@chromium.orgDelay post-insertion notifications until new DOM tree...
2012-03-29 caio.oliveira@open... HashMap<>::add should return a more descriptive object
2011-12-16 adamk@chromium.orgImprove performance of ChildListMutationScope when...
2011-12-16 adamk@chromium.org[MutationObservers] Add a document-level flag that...
2011-12-14 adamk@chromium.org[MutationObservers] Avoid allocations if no observers...
2011-12-09 adamk@chromium.orgUse HashMap<Node*, OwnPtr<...>> in ChildListMutationScope
2011-12-08 commit-queue@webki... Unreviewed, rolling out r102267.
2011-12-07 adamk@chromium.orgUse HashMap<Node*, OwnPtr<...>> in ChildListMutationScope
2011-11-23 commit-queue@webki... [MutationObservers] Cleanup duplicated code in Element...
2011-11-05 commit-queue@webki... [MutationObservers] Refactor MutationObserverRegistrati...
2011-11-04 adamk@chromium.orgReduce refcount churn in ChildListMutationScope
2011-10-27 commit-queue@webki... [MutationObservers] Implement subtree observation of...
2011-10-24 commit-queue@webki... Node::registeredMutationObserversOfType should be prefi...
2011-10-21 adamk@chromium.org[MutationObservers] Implement WebKitMutationObserver...