Remove excessive headers from JavaScriptCore
[WebKit-https.git] / Source / WebCore / bridge / NP_jsobject.cpp
2017-06-25 annulen@yandex.ruRemove excessive headers from JavaScriptCore
2016-12-26 utatane.tea@gmail.comPropagate the source origin as much as possible
2016-09-07 mark.lam@apple.comAdd CatchScope and force all exception checks to be...
2016-03-05 utatane.tea@gmail.com[ES6] Support Reflect.construct
2016-03-04 commit-queue@webki... Added missing override specifiers under Source/WebCore.
2015-09-17 gyuyoung.kim@webki... Remove all uses of PassRefPtr in WebCore/bindings
2015-07-24 utatane.tea@gmail.comObject.getOwnPropertySymbols on large list takes very...
2015-04-02 utatane.tea@gmail.comClean up EnumerationMode to easily extend
2015-01-06 andersca@apple.comStop including PluginView.h from cross platform WebCore...
2014-12-25 mitz@apple.comBring the state of WEBCORE_EXPORT annotations closer...
2014-03-21 svillar@igalia.comReplace DEPRECATED_DEFINE_STATIC_LOCAL by static NeverD...
2014-03-15 mjs@apple.com.: Replace "Apple Computer, Inc." with "Apple Inc....
2014-03-14 svillar@igalia.comRename DEFINE_STATIC_LOCAL to DEPRECATED_DEFINE_STATIC_...
2014-01-02 oliver@apple.comRefactor PutPropertySlot to be aware of custom properties
2013-12-26 commit-queue@webki... Unreviewed, rolling out r161033 and r161074.
2013-12-24 oliver@apple.comRefactor PutPropertySlot to be aware of custom properties
2013-09-03 darin@apple.comCut down on double hashing and code needlessly using...
2013-07-25 oliver@apple.comfourthTier: Rationalized 'this' conversion, includes...
2012-10-07 benjamin@webkit.orgRename first/second to key/value in HashMap iterators
2012-09-14 benjamin@webkit.orgImprove the SourceProvider hierarchy
2012-09-08 benjamin@webkit.orgRename the ustring() accessor to string()
2012-09-06 weinig@apple.comPart 2 of removing PlatformString.h, remove PlatformStr...
2012-08-30 ggaren@apple.comUse one object instead of two for closures, eliminating...
2012-08-30 benjamin@webkit.orgReplace JSC::UString by WTF::String
2012-08-28 commit-queue@webki... Unreviewed, rolling out r126914.
2012-08-28 caio.oliveira@open... Rename first/second to key/value in HashMap iterators
2012-08-28 tkent@chromium.orgUnreviewed, rolling out r126836.
2012-08-28 caio.oliveira@open... Rename first/second to key/value in HashMap iterators
2012-06-27 mhahnenberg@apple.comJSLock should be per-JSGlobalData
2012-06-23 zandobersek@gmail.comUnreviewed, rolling out r121058.
2012-06-22 mhahnenberg@apple.comJSLock should be per-JSGlobalData
2012-06-14 commit-queue@webki... make sure headers are included only once per file
2012-04-28 ggaren@apple.comClarified JSGlobalData (JavaScript VM) lifetime
2012-03-29 caio.oliveira@open... HashMap<>::add should return a more descriptive object
2012-03-06 barraclough@apple.computByIndex should throw in strict mode
2011-11-04 mhahnenberg@apple.comDe-virtualize JSObject::getPropertyNames
2011-11-03 darin@apple.comChange remaining callers of releaseRef to call leakRef
2011-10-27 mhahnenberg@apple.comDe-virtualize JSCell::toThisObject
2011-10-26 mhahnenberg@apple.comRemove deletePropertyVirtual
2011-10-26 mhahnenberg@apple.comRemove putVirtual
2011-10-15 mhahnenberg@apple.comRename virtual put to putVirtual
2011-10-14 mhahnenberg@apple.comRename virtual deleteProperty to deletePropertyVirtual
2011-09-08 weinig@apple.comRemove the Completion object from JSC, I have never...
2011-07-18 barraclough@apple.comSpeculative fix for Leopard assertions caused by 91095.
2011-02-15 oliver@apple.com2011-02-14 Oliver Hunt <oliver@apple.com>
2011-01-08 abarth@webkit.orgMove WebCore into Source