Use modern for-loops in WebCore/Modules - 2
[WebKit-https.git] / Source / WebCore / Modules / webdatabase / DatabaseTracker.cpp
2015-06-08 commit-queue@webki... Use modern for-loops in WebCore/Modules - 2
2015-06-02 andersca@apple.comUse UUIDs for WebSQL database filenames instead of...
2015-05-21 gyuyoung.kim@webki... Purge PassRefPtr in WebCore/Modules
2015-05-11 dbates@webkit.org[iOS] Close all open databases in expiration handler...
2015-04-05 commit-queue@webki... Use constants of sqlite3 directly for status of SQL...
2015-04-05 simon.fraser@apple.comRemove "go ahead and" from comments
2015-03-22 andersca@apple.com_WKWebsiteDataStore should clear WebSQL databases
2015-01-16 ossy@webkit.orgRemove ENABLE(SQL_DATABASE) guards
2015-01-13 andersca@apple.comRemove pure virtual functions from DatabaseBackendBase
2015-01-12 andersca@apple.comMerge DatabaseBackendContext into DatabaseContext
2014-03-18 svillar@igalia.comwebdatabase: Replace DEPRECATED_DEFINE_STATIC_LOCAL...
2014-03-15 mjs@apple.com.: Replace "Apple Computer, Inc." with "Apple Inc....
2014-03-14 svillar@igalia.comRename DEFINE_STATIC_LOCAL to DEPRECATED_DEFINE_STATIC_...
2014-02-03 zandobersek@gmail.comMove the webdatabase module source code to std::unique_ptr
2014-01-28 ap@apple.comExpose SQL database creation and modification times
2014-01-10 dbates@webkit.org[iOS] Upstream WebCore and Tools miscellaneous changes
2014-01-04 zandobersek@gmail.comExplicitly use the std:: nested name specifier when...
2013-12-14 bfulgham@apple.comSource/WebCore: [Win] Remove pre-VS2013 support code.
2013-10-25 andersca@apple.comStop bringing in the std namespace
2013-10-18 andersca@apple.comRemove spaces between template angle brackets
2013-05-06 weinig@apple.comRemove empty function SQLiteFileSystem::registerSQLiteV...
2013-04-05 benjamin@webkit.orgClean the chromium bits of WebCore's WebDatabase
2013-03-11 mark.lam@apple.comRemove the use of the quotaMap cache in DatabaseTracker.
2013-03-05 mark.lam@apple.comImprove robustness of WebSQL quota management.
2013-02-26 mark.lam@apple.comNeed a more robust WebSQL disk usage computation.
2013-02-25 mark.lam@apple.comChanged DatabaseTracker::getMaxSizeForDatabase() to...
2013-02-22 mark.lam@apple.comAdd some checks to DatabaseTracker::getMaxSizeForDataba...
2013-02-20 mark.lam@apple.comRename DatabaseBackend to DatabaseBackendBase.
2013-02-06 mark.lam@apple.comSplit openDatabase() between front and back end work.
2013-02-05 mark.lam@apple.comIntroduced back-end database classes + a few small...
2013-02-01 mark.lam@apple.comClean up calls to DatabaseTracker::add/removeOpenDataba...
2013-01-30 mark.lam@apple.comRename AbstractDatabase to DatabaseBackend.
2013-01-29 mark.lam@apple.comChange DatabaseContext lookup to be thread-safe.
2013-01-08 mark.lam@apple.comRemoved the need for the ProposedDatabase mechanism.
2012-12-12 mark.lam@apple.comEncapsulate externally used webdatabase APIs in Databas...
2012-10-07 benjamin@webkit.orgRename first/second to key/value in HashMap iterators
2012-08-28 commit-queue@webki... Unreviewed, rolling out r126914.
2012-08-28 caio.oliveira@open... Rename first/second to key/value in HashMap iterators
2012-08-28 tkent@chromium.orgUnreviewed, rolling out r126836.
2012-08-28 caio.oliveira@open... Rename first/second to key/value in HashMap iterators
2012-08-24 commit-queue@webki... Populate DatabaseTracker's origins lazily on demand
2012-05-05 aestes@apple.comRemove uses of ASSERT(false)
2012-03-06 abarth@webkit.orgMove SQLDatabase code into Modules/webdatabase