Get rid of HeapRootVisitor and make SlotVisitor less painful to use
[WebKit-https.git] / Source / JavaScriptCore / runtime / WeakMapData.cpp
2016-12-16 fpizlo@apple.comGet rid of HeapRootVisitor and make SlotVisitor less...
2016-09-08 fpizlo@apple.comRemove CopiedSpace and use MarkedSpace instead
2016-09-06 fpizlo@apple.comButterflies should be allocated in Auxiliary MarkedSpac...
2016-08-24 fpizlo@apple.comUnreviewed, roll out r204901, r204897, r204866, r204856...
2016-08-23 fpizlo@apple.comButterflies should be allocated in Auxiliary MarkedSpac...
2016-03-01 commit-queue@webki... Add new MethodTable method to get an estimated size...
2015-10-05 fpizlo@apple.comAllow an object's marking state to track The Three...
2015-03-11 ggaren@apple.comRefactored the JSC::Heap extra cost API for clarity...
2014-07-30 akling@apple.comStatic hash tables no longer need to be coupled with...
2014-01-10 mhahnenberg@apple.comMarking should be generational
2014-01-09 commit-queue@webki... Unreviewed, rolling out r161540.
2014-01-09 mhahnenberg@apple.comMarking should be generational
2013-09-11 commit-queue@webki... MapData and WeakMapData don't need to be objects
2013-09-10 oliver@apple.comSupport WeakMap