Rename activation to be more in line with spec language
[WebKit-https.git] / Source / JavaScriptCore / runtime / JSScope.h
2014-09-11 oliver@apple.comRename activation to be more in line with spec language
2014-09-09 commit-queue@webki... Unreviewed, rolling out r173402.
2014-09-08 mark.lam@apple.comMove CallFrame and Register inlines functions out of...
2014-08-29 mark.lam@apple.comDebuggerCallFrame::scope() should return a DebuggerScope.
2014-08-20 oliver@apple.comStop implicitly skipping a function's own activation...
2014-08-09 mark.lam@apple.comREGRESSION: Inspector crashes when debugger is paused...
2014-08-06 fpizlo@apple.comMerge r170564, r170571, r170604, r170628, r170672,...
2014-08-01 akling@apple.comRemove the JSC::OverridesVisitChildren flag.
2014-02-01 mark.lam@apple.comAvoid eagerly creating the JSActivation when the debugg...
2013-11-28 fpizlo@apple.comInfer one-time scopes
2013-11-27 fpizlo@apple.comRestructure global variable constant inference so that...
2013-11-18 fpizlo@apple.comput_to_scope[5] should not point to the structure if...
2013-10-02 ggaren@apple.comOptimized VM access from C++ code
2013-07-25 ryuan.choi@samsung.comUnreviewed, build fix on the EFL port.
2013-07-25 kadam@inf.u-szeged.huUnreviewed buildfix after FTL upstream.
2013-07-25 oliver@apple.comfourthTier: Re-worked non-local variable resolution
2013-04-18 ggaren@apple.comRenamed JSGlobalData to VM
2012-10-18 oliver@apple.comBytecode should not have responsibility for determining...
2012-10-18 oliver@apple.comRoll out r131645 as it causes random site crashes.
2012-10-17 oliver@apple.comBytecode should not have responsibility for determining...
2012-10-17 ossy@webkit.orgUnreviewed, rolling out r131516 and r131550.
2012-10-16 oliver@apple.comBytecode should not have responsibility for determining...
2012-09-01 ggaren@apple.com2012-09-01 Geoffrey Garen <ggaren@apple.com>
2012-08-31 ggaren@apple.comNot reviewed.
2012-08-31 ggaren@apple.comShrink activation objects by half
2012-08-30 ggaren@apple.comUse one object instead of two for closures, eliminating...
2012-08-29 ggaren@apple.comIntroduced JSWithScope, making all scope objects subcla...
2012-08-29 ggaren@apple.comAdded JSScope::objectInScope(), and refactored callers...
2012-08-28 ggaren@apple.com2012-08-28 Geoffrey Garen <ggaren@apple.com>