Rename dataLog() and dataLogV() to dataLogF() and dataLogFV()
[WebKit-https.git] / Source / JavaScriptCore / dfg / DFGStructureCheckHoistingPhase.cpp
2012-11-22 fpizlo@apple.comRename dataLog() and dataLogV() to dataLogF() and dataL...
2012-10-18 oliver@apple.comBytecode should not have responsibility for determining...
2012-10-18 oliver@apple.comRoll out r131645 as it causes random site crashes.
2012-10-17 oliver@apple.comBytecode should not have responsibility for determining...
2012-10-17 ossy@webkit.orgUnreviewed, rolling out r131516 and r131550.
2012-10-16 oliver@apple.comBytecode should not have responsibility for determining...
2012-10-14 fpizlo@apple.comDFG structure check hoisting should attempt to ignore...
2012-10-07 benjamin@webkit.orgRename first/second to key/value in HashMap iterators
2012-09-28 fpizlo@apple.comDFGStructureHoistingPhase SetLocal assumes StructureTra...
2012-09-26 fpizlo@apple.comDFG ArrayPush, ArrayPop don't handle clobbering or...
2012-09-25 fpizlo@apple.comStructure check hoisting phase doesn't know about the...
2012-09-16 fpizlo@apple.comStructure check hoisting fails to consider the possibil...
2012-09-13 fpizlo@apple.comJSC should have property butterflies
2012-08-28 commit-queue@webki... Unreviewed, rolling out r126914.
2012-08-28 caio.oliveira@open... Rename first/second to key/value in HashMap iterators
2012-08-28 tkent@chromium.orgUnreviewed, rolling out r126836.
2012-08-28 caio.oliveira@open... Rename first/second to key/value in HashMap iterators
2012-08-28 fpizlo@apple.comStructure check hoisting should abstain if the OSR...
2012-08-26 fpizlo@apple.comArray type checks and storage accesses should be unifor...
2012-08-23 fpizlo@apple.comArray accesses should remember what kind of array they...
2012-08-20 fpizlo@apple.comThe relationship between abstract values and structure...
2012-08-18 fpizlo@apple.comDFG is still too pessimistic about what constitutes...
2012-08-16 fpizlo@apple.comStructure check hoisting should be less expensive
2012-08-15 fpizlo@apple.comArray checks should use the structure, not the class...
2012-08-03 fpizlo@apple.comDFG::StructureCheckHoistingPhase keeps a Node& around...
2012-08-02 fpizlo@apple.comUnreviewed, build fix for DFG_ENABLE(DEBUG_PROPAGATION_...
2012-08-02 fpizlo@apple.comDFG should hoist structure checks