Rename dataLog() and dataLogV() to dataLogF() and dataLogFV()
[WebKit-https.git] / Source / JavaScriptCore / dfg / DFGArgumentsSimplificationPhase.cpp
2012-11-22 fpizlo@apple.comRename dataLog() and dataLogV() to dataLogF() and dataL...
2012-10-28 fpizlo@apple.comDFG::Array::Mode needs to be cleaned up
2012-10-07 benjamin@webkit.orgRename first/second to key/value in HashMap iterators
2012-09-20 ggaren@apple.comRefactored the interpreter and JIT so they don't dictat...
2012-09-20 ggaren@apple.comOSR exit sometimes neglects to create the arguments...
2012-09-14 ggaren@apple.comRefactored the DFG to make fewer assumptions about...
2012-09-10 ggaren@apple.comRefactored op_tear_off* to support activations that...
2012-08-28 commit-queue@webki... Unreviewed, rolling out r126914.
2012-08-28 caio.oliveira@open... Rename first/second to key/value in HashMap iterators
2012-08-28 tkent@chromium.orgUnreviewed, rolling out r126836.
2012-08-28 caio.oliveira@open... Rename first/second to key/value in HashMap iterators
2012-08-26 fpizlo@apple.comArray type checks and storage accesses should be unifor...
2012-08-23 fpizlo@apple.comArray accesses should remember what kind of array they...
2012-08-20 fpizlo@apple.comThe relationship between abstract values and structure...
2012-08-16 fpizlo@apple.comStructure check hoisting should be less expensive
2012-08-15 fpizlo@apple.comArray checks should use the structure, not the class...
2012-07-03 fpizlo@apple.comDFG OSR exit value recoveries should be computed lazily
2012-07-03 fpizlo@apple.comDFG::ArgumentsSimplificationPhase should assert that...
2012-06-07 fpizlo@apple.comPredictedType should be called SpeculatedType
2012-06-05 fpizlo@apple.comDFG arguments simplification should have rationalized...
2012-06-04 fpizlo@apple.comDFG arguments simplification takes unkindly to direct...
2012-06-02 fpizlo@apple.comDFG CSE should be able to eliminate unnecessary flushes...
2012-06-01 fpizlo@apple.comDFG arguments simplification phase uses a node.codeOrig...
2012-05-25 fpizlo@apple.comDFG CSE should do redundant store elimination
2012-05-24 fpizlo@apple.comUnreviewed, merge the arguments fix in r118138 to get...
2012-05-24 fpizlo@apple.comDFG should optimize aliased uses of the Arguments objec...
2012-05-24 fpizlo@apple.comDFG should optimize inlined uses of arguments.length...