Rename dataLog() and dataLogV() to dataLogF() and dataLogFV()
[WebKit-https.git] / Source / JavaScriptCore / dfg / DFGAbstractValue.h
2012-11-22 fpizlo@apple.comRename dataLog() and dataLogV() to dataLogF() and dataL...
2012-11-17 fpizlo@apple.comGiven a PutById or GetById with a proven structure...
2012-11-12 fpizlo@apple.comDFG should not emit function checks if we've already...
2012-10-26 fpizlo@apple.comDFG Arrayify elimination should replace it with GetButt...
2012-10-20 fpizlo@apple.comDFG should have some facility for recognizing redundant...
2012-08-20 fpizlo@apple.comThe relationship between abstract values and structure...
2012-08-19 fpizlo@apple.comThe current state of the call frame should be taken...
2012-08-15 fpizlo@apple.comArray checks should use the structure, not the class...
2012-08-02 fpizlo@apple.comDFG should hoist structure checks
2012-06-07 fpizlo@apple.comPredictedType should be called SpeculatedType
2012-05-18 fpizlo@apple.comDFG should have control flow graph simplification
2012-05-18 fpizlo@apple.comDFG should have constant propagation
2012-02-27 fpizlo@apple.comLayoutTests/fast/xpath/xpath-functional-test.html is...
2012-02-02 fpizlo@apple.comRelease build debugging should be easier
2012-01-22 fpizlo@apple.comDFG should not have code that directly decodes the...
2011-11-22 fpizlo@apple.comDFG should have richer debug output for CFA and phi...
2011-10-13 fpizlo@apple.comDFG CFA does not filter structures aggressively enough.
2011-10-12 fpizlo@apple.comLayout tests crashing in DFG JIT code
2011-10-12 fpizlo@apple.comDFG does not have flow-sensitive intraprocedural contro...