Rename activation to be more in line with spec language
[WebKit-https.git] / Source / JavaScriptCore / bytecode / UnlinkedCodeBlock.h
2014-09-11 oliver@apple.comRename activation to be more in line with spec language
2014-08-21 commit-queue@webki... Rename HighFidelityTypeProfiling variables for more...
2014-08-06 fpizlo@apple.comMerge r171389, r171495, r171508, r171510, r171605,...
2014-08-06 fpizlo@apple.comMerge r170564, r170571, r170604, r170628, r170672,...
2014-08-01 akling@apple.comRemove the JSC::OverridesVisitChildren flag.
2014-06-16 mark.lam@apple.comParser statementDepth accounting needs to account for...
2014-06-12 mark.lam@apple.comRemove some dead / unused code.
2014-05-01 commit-queue@webki... Unreviewed, rolling out r167964.
2014-04-29 oliver@apple.comSource/JavaScriptCore: Don't hold on to parameterBindin...
2014-04-25 oliver@apple.comRemove unused parameter from codeblock linking function
2014-02-27 mhahnenberg@apple.comMake JSCells have 32-bit Structure pointers
2014-02-12 oliver@apple.comMake it possible to implement JS builtins in JS
2014-02-04 akling@apple.comKeep only captured symbols in CodeBlock symbol tables.
2014-02-03 ggaren@apple.comSimplified name scope creation for function expressions
2014-02-01 oliver@apple.com2014-01-31 Oliver Hunt <oliver@apple.com>
2014-02-01 mark.lam@apple.comAvoid eagerly creating the JSActivation when the debugg...
2014-01-31 oliver@apple.comMake it possible to implement JS builtins in JS
2014-01-27 akling@apple.comJSC: Pack unlinked instructions harder.
2014-01-21 fpizlo@apple.comop_captured_mov and op_new_captured_func in UnlinkedCod...
2014-01-21 mark.lam@apple.comRemoving CodeBlock::opDebugBytecodeOffsetForLineAndColu...
2014-01-18 mark.lam@apple.comAdding UnlinkedCodeBlock::opDebugBytecodeOffsetForLineA...
2013-12-04 fpizlo@apple.comInfer constant closure variables
2013-11-22 fpizlo@apple.comCombine SymbolTable and SharedSymbolTable
2013-11-19 mark.lam@apple.comAdd tracking of endColumn for Executables.
2013-10-18 andersca@apple.comRemove spaces between template angle brackets
2013-09-26 msaboff@apple.comVirtualRegister should be a class
2013-09-26 commit-queue@webki... Unreviewed, rolling out r156474.
2013-09-26 msaboff@apple.comVirtualRegister should be a class
2013-09-23 oliver@apple.comCodeLoad performance regression
2013-09-10 msaboff@apple.comThere should be one "invalid" virtual register constant
2013-08-23 oliver@apple.comSupport in memory compression of rarely used data
2013-08-14 fpizlo@apple.comFoo::s_info should be Foo::info(), so that you can...
2013-07-25 oliver@apple.comfourthTier: There should only be one table of SimpleJum...
2013-07-25 oliver@apple.comfourthTier: Re-worked non-local variable resolution
2013-07-09 mark.lam@apple.comFix 30% JSBench regression (caused by adding column...
2013-05-09 oliver@apple.comCode cache stores bogus var references for functions...
2013-04-18 ggaren@apple.comRenamed JSGlobalData to VM
2013-04-08 ggaren@apple.comStop #include-ing all of JavaScriptCore in every DOM...
2013-04-08 oliver@apple.comAdd bounds checking for WTF::Vector::operator[]
2013-03-07 oliver@apple.comBring back eager resolution of function scoped variables
2013-02-18 fpizlo@apple.comMove all Structure out-of-line inline methods to Struct...
2013-02-17 ggaren@apple.comCode cache should be explicit about what it caches
2013-02-12 commit-queue@webki... Unreviewed, rolling out r142387.
2013-02-10 akling@apple.comShrink-wrap UnlinkedCodeBlock members.
2013-01-29 ggaren@apple.comStatic size inference for JavaScript objects
2012-11-30 oliver@apple.comAdd direct string->function code cache
2012-11-09 oliver@apple.comImprove effectiveness of function-level caching
2012-11-08 fpizlo@apple.comJSC should infer when indexed storage contains only...
2012-11-07 oliver@apple.comReduce parser overhead in JSC