op_in should mark if it sees out of bounds accesses
[WebKit-https.git] / Source / JavaScriptCore / bytecode / ArrayProfile.cpp
2018-05-18 keith_miller@apple.comop_in should mark if it sees out of bounds accesses
2017-12-07 darin@apple.comModernize some aspects of text codecs, eliminate WebKit...
2016-11-15 fpizlo@apple.comRename CONCURRENT_JIT/ConcurrentJIT to CONCURRENT_JS...
2015-06-05 benjamin@webkit.org[JSC] Always track out-of-bounds array access explicitl...
2015-04-28 benjamin@webkit.org[JSC] Add support for typed arrays to the Array profiling
2014-02-27 mhahnenberg@apple.comMake JSCells have 32-bit Structure pointers
2014-02-11 fpizlo@apple.comRename Operations.h to JSCInlines.h
2014-02-10 fpizlo@apple.comNever include *Inlines.h files in interface headers...
2013-09-18 fpizlo@apple.comUse CheckStructure for checking the types of typed...
2013-07-25 commit-queue@webki... Build fix: add missing #include.
2013-07-25 oliver@apple.comfourthTier: DFG IR dumps should be easier to read
2013-07-25 oliver@apple.comfourthTier: DFG shouldn't create CheckStructures for...
2013-07-25 oliver@apple.comfourthTier: Have fewer Arrayify's
2013-07-25 oliver@apple.comfourthTier: should use ConcurrentJITLock[er] directly...
2013-07-25 oliver@apple.comfourthTier: value profiles and array profiles should...
2013-03-27 fpizlo@apple.comDFG should use CheckStructure for typed array checks...
2012-12-17 fpizlo@apple.comRationalize array profiling for out-of-bounds and hole...
2012-12-12 fpizlo@apple.comProfiler should show bytecode dumps as they would have...
2012-11-08 fpizlo@apple.comJSC should infer when indexed storage contains only...
2012-10-29 fpizlo@apple.comDFG should be able to emit effectful structure checks
2012-10-26 fpizlo@apple.comDFG Arrayify elimination should replace it with GetButt...
2012-10-20 fpizlo@apple.comDFG should have some facility for recognizing redundant...
2012-09-19 fpizlo@apple.comDFG should not call out to C++ every time that it tries...
2012-09-17 fpizlo@apple.comArray profiling has convergence issues
2012-08-15 fpizlo@apple.comArray checks should use the structure, not the class...