Get rid of method_check
[WebKit-https.git] / Source / JavaScriptCore / CMakeLists.txt
2012-11-06 fpizlo@apple.comGet rid of method_check
2012-10-21 rakuco@webkit.orgFix 'make dist' for the GTK+ port
2012-10-18 rakuco@webkit.org[CMake] Avoid unnecessarily running the LLInt generatio...
2012-10-12 mhahnenberg@apple.comCopying collection shouldn't require O(live bytes)...
2012-10-10 fpizlo@apple.comTyped arrays should not be 20x slower in the baseline...
2012-10-09 fpizlo@apple.comJSC should infer when indexed storage is contiguous...
2012-10-09 mark.lam@apple.comRenamed RegisterFile to JSStack, and removed prototype...
2012-10-05 mhahnenberg@apple.comJSC should have a way to gather and log Heap memory...
2012-09-27 fpizlo@apple.comjneq_ptr shouldn't have a pointer
2012-09-26 barraclough@apple.comGeneralize JSGlobalThis as JSProxy
2012-09-13 fpizlo@apple.comJSC should have property butterflies
2012-09-11 rakuco@webkit.org[EFL] Rewrite the EFL-related Find modules
2012-09-11 rakuco@webkit.org[EFL] Unreviewed build fix after r128065.
2012-09-10 mhahnenberg@apple.comCombine MarkStack and SlotVisitor into single class
2012-09-10 commit-queue@webki... [CMake][EFL] Enable the LLInt
2012-08-30 ggaren@apple.comUse one object instead of two for closures, eliminating...
2012-08-30 benjamin@webkit.orgReplace JSC::UString by WTF::String
2012-08-29 ggaren@apple.comIntroduced JSWithScope, making all scope objects subcla...
2012-08-28 ggaren@apple.comRefactored and consolidated variable resolution functions
2012-08-25 fpizlo@apple.comThe redundant phi elimination phase is not used and...
2012-08-23 fpizlo@apple.comArray accesses should remember what kind of array they...
2012-08-22 mhahnenberg@apple.comSeparate MarkStackThreadSharedData from MarkStack
2012-08-22 commit-queue@webki... Introducing the VMInspector for VM debugging use.
2012-08-15 fpizlo@apple.comArray checks should use the structure, not the class...
2012-08-02 fpizlo@apple.comDFG should hoist structure checks
2012-07-13 fpizlo@apple.comDFG property access stubs should use structure transiti...
2012-07-11 fpizlo@apple.comWatchpoints and jump replacement should be decoupled
2012-07-09 fpizlo@apple.comIt should be possible to jettison JIT stub routines...
2012-07-03 fpizlo@apple.comDFG OSR exit value recoveries should be computed lazily
2012-06-21 fpizlo@apple.comDFG should optimize ResolveGlobal
2012-06-20 fpizlo@apple.comDFG should be able to print disassembly interleaved...
2012-06-20 fpizlo@apple.comJSC should be able to show disassembly for all generate...
2012-06-19 fpizlo@apple.comIt should be possible to look at disassembly
2012-06-19 mhahnenberg@apple.comGCActivityCallback and IncrementalSweeper should share...
2012-06-13 fpizlo@apple.comDFG should be able to set watchpoints on global variables
2012-06-13 zandobersek@gmail.comUnreviewed, rolling out r120172.
2012-06-13 fpizlo@apple.comDFG should be able to set watchpoints on global variables
2012-06-07 fpizlo@apple.comPredictedType should be called SpeculatedType
2012-06-07 fpizlo@apple.comGlobal object variable accesses should not require...
2012-05-31 mhahnenberg@apple.comHeap should sweep incrementally
2012-05-24 fpizlo@apple.comDFG should optimize inlined uses of arguments.length...
2012-05-22 fpizlo@apple.comDFG should be able to compute dominators
2012-05-22 barraclough@apple.comAdd support for private names
2012-05-18 fpizlo@apple.comDFG should have control flow graph simplification
2012-05-18 fpizlo@apple.comDFG should have constant propagation
2012-04-29 ggaren@apple.comFactored threaded block allocation into a separate...
2012-04-25 kbr@google.comDelete CanvasPixelArray, ByteArray, JSByteArray and...
2012-04-10 paroga@webkit.org[CMake] Enable USE_FOLDERS property
2012-04-06 ggaren@apple.comRenamed
2012-04-05 benjamin@webkit.orgMake something faster than JSStringBuilder for joining...
2012-04-04 ggaren@apple.comFirst step toward incremental Weak<T> finalization
2012-03-26 barraclough@apple.comGreek sigma is handled wrong in case independent regexp.
2012-03-24 fpizlo@apple.comDFG Fixup should be able to short-circuit trivial Value...
2012-03-23 barraclough@apple.comRexExp constructor last match properties should not...
2012-03-23 kubo@profusion.mobi[CMake] Unreviewed build fix after r111778.
2012-03-21 eric@webkit.orgMove wtf/Platform.h from JavaScriptCore to Source/WTF/wtf
2012-03-13 fpizlo@apple.comArithmetic use inference should be procedure-global...
2012-03-12 fpizlo@apple.comNode::op and Node::flags should be private
2012-03-12 fpizlo@apple.comAll DFG nodes should have a mutable set of flags
2012-03-08 yuqiang.xian@intel.comEliminate redundant Phis in DFG
2012-03-07 kubo@profusion.mobi[CMake] Make the removal of transitive library dependen...
2012-03-05 fpizlo@apple.comJIT heuristics should be hyperbolic
2012-03-05 kubo@profusion.mobi[CMake] Libraries are installed to /usr/lib and not...
2012-02-23 fpizlo@apple.comDFG OSR exit value profiling should have graceful handl...
2012-02-23 paroga@webkit.org[CMake] Add WEBKIT_INCLUDE_CONFIG_FILES_IF_EXISTS macro
2012-02-22 fpizlo@apple.comJSC should be a triple-tier VM
2012-02-21 aroben@apple.comRoll out r108309, r108323, and r108326
2012-02-21 fpizlo@apple.comJSC should be a triple-tier VM
2012-02-18 fpizlo@apple.comDFGPropagator.cpp has too many things
2012-02-17 mhahnenberg@apple.comRename Bump* to Copy*
2012-02-12 kubo@profusion.mobi[CMake] Remove unused or empty variable definitions.
2012-02-11 fpizlo@apple.comDFG should have polymorphic put_by_id caching
2012-02-03 mhahnenberg@apple.comRefactor MarkedBlock::SizeClass into a separate class
2012-01-29 barraclough@apple.comImplement a JIT-code aware sampling profiler for JSC
2012-01-27 mhahnenberg@apple.comMerge AllocationSpace into MarkedSpace
2012-01-27 fpizlo@apple.comAll DFG helpers that may call out to arbitrary JS code...
2012-01-22 fpizlo@apple.comDFG should not have code that directly decodes the...
2012-01-19 mhahnenberg@apple.comImplement a new allocator for backing stores
2012-01-11 fpizlo@apple.comCodeBlock.h declares too many things
2012-01-08 fpizlo@apple.comThe JIT's protocol for exception handling should be...
2011-12-15 commit-queue@webki... Rename JSC::Heuristics to JSC::Options
2011-12-13 fpizlo@apple.comDFG should know exactly why recompilation was triggered
2011-11-23 paroga@webkit.org[CMake] Move the top-level logic to the top-level direc...
2011-11-17 fpizlo@apple.comCode block jettisoning should be part of the GC's trans...
2011-11-15 fpizlo@apple.comDFG::SpeculativeJIT and DFG::JITCodeGenerator should...
2011-11-15 abarth@webkit.orgDateMath.cpp should not depend on JavaScriptCore
2011-11-12 paroga@webkit.org[CMake] Move list of DFG source files into correct...
2011-11-10 ryuan.choi@samsung.com[CMAKE] Refactoring CMakeLists${PORT}.txt to Platform...
2011-10-31 weinig@apple.comRemove need for virtual JSObject::unwrappedObject
2011-10-31 msaboff@apple.comTowards 8-bit Strings: Move Lexer and Parser Objects...
2011-10-19 ggaren@apple.comSome rope cleanup following r97827
2011-10-01 fpizlo@apple.comAll of JSC's heuristics should be in one place for...
2011-09-22 barraclough@apple.comImplement Function.prototype.bind
2011-09-21 fpizlo@apple.comDFG should support continuous optimization
2011-09-20 oliver@apple.comRefactor Heap allocation logic into separate Allocation...
2011-09-20 commit-queue@webki... Unreviewed, rolling out r95493 and r95496.
2011-09-19 oliver@apple.comRefactor Heap allocation logic into separate Allocation...
2011-09-19 oliver@apple.comRename NewSpace.{h,cpp} to MarkedSpace.{h,cpp}
2011-09-14 fpizlo@apple.comTiered compilation heuristics do not account for value...
2011-09-07 oliver@apple.comRemove JSObjectWithGlobalObject
next