[CMake][EFL] Should try to find the same libsoup version pulled by jhbuild
authorcommit-queue@webkit.org <commit-queue@webkit.org@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Thu, 19 Jul 2012 04:47:59 +0000 (04:47 +0000)
committercommit-queue@webkit.org <commit-queue@webkit.org@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Thu, 19 Jul 2012 04:47:59 +0000 (04:47 +0000)
https://bugs.webkit.org/show_bug.cgi?id=91626

Patch by Christophe Dumez <christophe.dumez@intel.com> on 2012-07-18
Reviewed by Kenneth Rohde Christiansen.

.:

Bump required version of libsoup in CMake to 2.39.3. This is the first
tarball version to contain the API we need (soup_cookie_jar_get_cookies()
and soup_cookie_jar_set_cookie_with_first_party()).

* Source/cmake/OptionsEfl.cmake:

Tools:

Update jhbuild to pull libsoup 2.39.3 tarball from Gnome FTP instead
of fetching a tag from Gnome GIT. We need to do this to map the version
of libsoup that is required by our CMake config.

* efl/jhbuild.modules:

git-svn-id: https://svn.webkit.org/repository/webkit/trunk@123069 268f45cc-cd09-0410-ab3c-d52691b4dbfc

ChangeLog
Source/cmake/OptionsEfl.cmake
Tools/ChangeLog
Tools/efl/jhbuild.modules

index c9b2701..4a2b9d6 100644 (file)
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,16 @@
+2012-07-18  Christophe Dumez  <christophe.dumez@intel.com>
+
+        [CMake][EFL] Should try to find the same libsoup version pulled by jhbuild
+        https://bugs.webkit.org/show_bug.cgi?id=91626
+
+        Reviewed by Kenneth Rohde Christiansen.
+
+        Bump required version of libsoup in CMake to 2.39.3. This is the first
+        tarball version to contain the API we need (soup_cookie_jar_get_cookies()
+        and soup_cookie_jar_set_cookie_with_first_party()).
+
+        * Source/cmake/OptionsEfl.cmake:
+
 2012-07-18  Varun Jain  <varunjain@chromium.org>
 
         [chromium] Drag image for image elements should be scaled with device scale factor.
index 889f22e..0a39534 100644 (file)
@@ -35,7 +35,7 @@ FIND_PACKAGE(ZLIB REQUIRED)
 
 FIND_PACKAGE(Glib 2.31.8 REQUIRED)
 FIND_PACKAGE(Gthread REQUIRED)
-FIND_PACKAGE(LibSoup2 2.37.92 REQUIRED)
+FIND_PACKAGE(LibSoup2 2.39.3 REQUIRED)
 SET(ENABLE_GLIB_SUPPORT ON)
 
 SET(WTF_USE_SOUP 1)
index 05c3bfd..abc235e 100644 (file)
@@ -1,3 +1,16 @@
+2012-07-18  Christophe Dumez  <christophe.dumez@intel.com>
+
+        [CMake][EFL] Should try to find the same libsoup version pulled by jhbuild
+        https://bugs.webkit.org/show_bug.cgi?id=91626
+
+        Reviewed by Kenneth Rohde Christiansen.
+
+        Update jhbuild to pull libsoup 2.39.3 tarball from Gnome FTP instead
+        of fetching a tag from Gnome GIT. We need to do this to map the version
+        of libsoup that is required by our CMake config.
+
+        * efl/jhbuild.modules:
+
 2012-07-18  MORITA Hajime  <morrita@google.com>
 
         Add window resize benchmark
index 9084d79..a90ad59 100644 (file)
     <dependencies>
       <dep package="glib-networking"/>
     </dependencies>
-    <branch module="libsoup" version="2.39.2"
-            repo="git.gnome.org"
-            tag="LIBSOUP_2_39_2"/>
+    <branch module="/pub/gnome/sources/libsoup/2.39/libsoup-2.39.3.tar.xz" version="2.39.3"
+            repo="ftp.gnome.org"
+            hash="sha256:db91194f4e0aaa7e3f87612c210875b5d64c92977f5c72b68672882d3572d45c"
+            md5sum="d0e94125762b85ab998c81b0187cd370"/>
   </autotools>
 
   <autotools id="fontconfig" autogen-sh="configure">