[GTK][WPE] install-dependencies can't find libapache2-mod-php7.0 on Ubuntu 17.10
authorcommit-queue@webkit.org <commit-queue@webkit.org@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Fri, 27 Oct 2017 04:04:18 +0000 (04:04 +0000)
committercommit-queue@webkit.org <commit-queue@webkit.org@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Fri, 27 Oct 2017 04:04:18 +0000 (04:04 +0000)
https://bugs.webkit.org/show_bug.cgi?id=178854

Patch by Fujii Hironori <Hironori.Fujii@sony.com> on 2017-10-26
Reviewed by Michael Catanzaro.

Tools:

* Scripts/webkitpy/port/base.py:
(Port._debian_php_version): Return "-php7.1" if libphp7.1.so found.
(Port._is_debian_php_version_7): Deleted.
* gtk/install-dependencies: Install libapache2-mod-php instead of libapache2-mod-php7.0.
* wpe/install-dependencies: Ditto.

LayoutTests:

* http/conf/debian-httpd-2.2.conf: Removed.
* http/conf/debian-httpd-2.4-php7.0.conf: Renamed from LayoutTests/http/conf/debian-httpd-2.4-php7.conf.
* http/conf/debian-httpd-2.4-php7.1.conf: Copied from LayoutTests/http/conf/debian-httpd-2.4-php7.conf.

git-svn-id: https://svn.webkit.org/repository/webkit/trunk@224084 268f45cc-cd09-0410-ab3c-d52691b4dbfc

LayoutTests/ChangeLog
LayoutTests/http/conf/debian-httpd-2.2.conf [deleted file]
LayoutTests/http/conf/debian-httpd-2.4-php7.0.conf [moved from LayoutTests/http/conf/debian-httpd-2.4-php7.conf with 100% similarity]
LayoutTests/http/conf/debian-httpd-2.4-php7.1.conf [moved from LayoutTests/http/conf/debian-httpd-2.4.conf with 97% similarity]
Tools/ChangeLog
Tools/Scripts/webkitpy/port/base.py
Tools/gtk/install-dependencies
Tools/wpe/install-dependencies

index 0d6710e..cd84ec6 100644 (file)
@@ -1,3 +1,14 @@
+2017-10-26  Fujii Hironori  <Hironori.Fujii@sony.com>
+
+        [GTK][WPE] install-dependencies can't find libapache2-mod-php7.0 on Ubuntu 17.10
+        https://bugs.webkit.org/show_bug.cgi?id=178854
+
+        Reviewed by Michael Catanzaro.
+
+        * http/conf/debian-httpd-2.2.conf: Removed.
+        * http/conf/debian-httpd-2.4-php7.0.conf: Renamed from LayoutTests/http/conf/debian-httpd-2.4-php7.conf.
+        * http/conf/debian-httpd-2.4-php7.1.conf: Copied from LayoutTests/http/conf/debian-httpd-2.4-php7.conf.
+
 2017-10-26  Devin Rousso  <webkit@devinrousso.com>
 
         Web Inspector: Canvas Tab: canvas path components from old page stick around when page is reloaded
diff --git a/LayoutTests/http/conf/debian-httpd-2.2.conf b/LayoutTests/http/conf/debian-httpd-2.2.conf
deleted file mode 100644 (file)
index ddaeaf1..0000000
+++ /dev/null
@@ -1,155 +0,0 @@
-ServerRoot "/usr"
-
-LockFile "/tmp/WebKit/httpd.lock"
-PidFile "/tmp/WebKit/httpd.pid"
-ScoreBoardFile "/tmp/WebKit/httpd.scoreboard"
-
-Timeout 300
-KeepAlive On
-MaxKeepAliveRequests 100
-KeepAliveTimeout 15
-
-MinSpareServers 1
-MaxSpareServers 5
-StartServers 1
-MaxClients 150
-MaxRequestsPerChild 100000
-
-LoadModule mime_module        /usr/lib/apache2/modules/mod_mime.so
-LoadModule negotiation_module /usr/lib/apache2/modules/mod_negotiation.so
-LoadModule include_module    /usr/lib/apache2/modules/mod_include.so
-LoadModule cgi_module         /usr/lib/apache2/modules/mod_cgi.so
-LoadModule asis_module        /usr/lib/apache2/modules/mod_asis.so
-LoadModule imagemap_module    /usr/lib/apache2/modules/mod_imagemap.so
-LoadModule actions_module      /usr/lib/apache2/modules/mod_actions.so
-LoadModule alias_module       /usr/lib/apache2/modules/mod_alias.so
-LoadModule rewrite_module     /usr/lib/apache2/modules/mod_rewrite.so
-LoadModule authz_host_module  /usr/lib/apache2/modules/mod_authz_host.so
-LoadModule headers_module     /usr/lib/apache2/modules/mod_headers.so
-LoadModule ssl_module         /usr/lib/apache2/modules/mod_ssl.so
-LoadModule php5_module        /usr/lib/apache2/modules/libphp5.so
-
-ServerName 127.0.0.1
-
-<Directory />
-    Options Indexes FollowSymLinks MultiViews ExecCGI Includes
-    AllowOverride All
-    Order allow,deny
-    Allow from all
-</Directory>
-
-AccessFileName .htaccess
-
-<Files ~ "^\.([Hh][Tt]|[Dd][Ss]_[Ss])">
-    Order allow,deny
-    Deny from all
-    Satisfy All
-</Files>
-
-UseCanonicalName On
-DefaultType text/plain
-HostnameLookups Off
-
-LogLevel warn
-LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined
-LogFormat "%h %l %u %t \"%r\" %>s %b" common
-LogFormat "%{Referer}i -> %U" referer
-LogFormat "%{User-agent}i" agent
-
-ServerSignature On
-
-<IfModule mod_alias.c>
-</IfModule>
-
-<IfModule mod_mime.c>
-    AddLanguage da .dk
-    AddLanguage nl .nl
-    AddLanguage en .en
-    AddLanguage et .ee
-    AddLanguage fr .fr
-    AddLanguage de .de
-    AddLanguage el .el
-    AddLanguage he .he
-    AddCharset ISO-8859-8 .iso8859-8
-    AddLanguage it .it
-    AddLanguage ja .ja
-    AddCharset ISO-2022-JP .jis
-    AddLanguage kr .kr
-    AddCharset ISO-2022-KR .iso-kr
-    AddLanguage nn .nn
-    AddLanguage no .no
-    AddLanguage pl .po
-    AddCharset ISO-8859-2 .iso-pl
-    AddLanguage pt .pt
-    AddLanguage pt-br .pt-br
-    AddLanguage ltz .lu
-    AddLanguage ca .ca
-    AddLanguage es .es
-    AddLanguage sv .sv
-    AddLanguage cs .cz .cs
-    AddLanguage ru .ru
-    AddLanguage zh-TW .zh-tw
-    AddCharset Big5         .Big5    .big5
-    AddCharset WINDOWS-1251 .cp-1251
-    AddCharset CP866        .cp866
-    AddCharset ISO-8859-5   .iso-ru
-    AddCharset KOI8-R       .koi8-r
-    AddCharset UCS-2        .ucs2
-    AddCharset UCS-4        .ucs4
-    AddCharset UTF-8        .utf8
-
-    <IfModule mod_negotiation.c>
-        LanguagePriority en da nl et fr de el it ja kr no pl pt pt-br ru ltz ca es sv tw
-    </IfModule>
-
-    AddType application/x-tar .tgz
-
-    AddEncoding x-compress .Z
-    AddEncoding x-gzip .gz .tgz
-
-    AddHandler cgi-script .cgi .pl
-
-    AddType text/html .shtml
-    AddHandler server-parsed .shtml
-
-    AddHandler send-as-is asis
-</IfModule>
-
-<IfModule mod_php5.c>
-    AddType application/x-httpd-php .php
-    AddType application/x-httpd-php .bat
-    AddType application/x-httpd-php-source .phps
-
-    <IfModule mod_dir.c>
-        DirectoryIndex index.html index.php
-    </IfModule>
-
-    php_flag log_errors on
-    php_flag short_open_tag on
-</IfModule>
-
-<IfModule mod_rewrite.c>
-    RewriteEngine On
-    RewriteCond %{REQUEST_METHOD} ^TRACE
-    RewriteRule .* - [F]
-</IfModule>
-
-<VirtualHost *:8443>
-    ServerName 127.0.0.1
-    SSLEngine On
-</VirtualHost>
-
-#
-# Apple-specific filesystem protection.
-#
-<Files "rsrc">
-    Order allow,deny
-    Deny from all
-    Satisfy All
-</Files>
-
-<Directory  ~ ".*\.\.namedfork">
-    Order allow,deny
-    Deny from all
-    Satisfy All
-</Directory>
@@ -27,7 +27,7 @@ LoadModule alias_module         modules/mod_alias.so
 LoadModule rewrite_module       modules/mod_rewrite.so
 LoadModule cgi_module           modules/mod_cgi.so
 LoadModule ssl_module           modules/mod_ssl.so
-LoadModule php5_module          modules/libphp5.so
+LoadModule php7_module          modules/libphp7.1.so
 LoadModule asis_module          modules/mod_asis.so
 
 ServerName 127.0.0.1
@@ -112,7 +112,7 @@ AddOutputFilter INCLUDES .shtml
 
 AddHandler send-as-is asis
 
-<IfModule mod_php5.c>
+<IfModule mod_php7.c>
     AddType application/x-httpd-php .php
     AddType application/x-httpd-php .bat
     AddType application/x-httpd-php-source .phps
index 99c40ee..b2f3524 100644 (file)
@@ -1,3 +1,16 @@
+2017-10-26  Fujii Hironori  <Hironori.Fujii@sony.com>
+
+        [GTK][WPE] install-dependencies can't find libapache2-mod-php7.0 on Ubuntu 17.10
+        https://bugs.webkit.org/show_bug.cgi?id=178854
+
+        Reviewed by Michael Catanzaro.
+
+        * Scripts/webkitpy/port/base.py:
+        (Port._debian_php_version): Return "-php7.1" if libphp7.1.so found.
+        (Port._is_debian_php_version_7): Deleted.
+        * gtk/install-dependencies: Install libapache2-mod-php instead of libapache2-mod-php7.0.
+        * wpe/install-dependencies: Ditto.
+
 2017-10-25  Simon Fraser  <simon.fraser@apple.com>
 
         When navigating back to a page, compositing layers may not use accelerated drawing
index 9934f71..aacbc38 100644 (file)
@@ -1201,11 +1201,6 @@ class Port(object):
             return True
         return False
 
-    def _is_debian_php_version_7(self):
-        if self._filesystem.exists("/usr/lib/apache2/modules/libphp7.0.so"):
-            return True
-        return False
-
     def _is_darwin_php_version_7(self):
         if self._filesystem.exists("/usr/libexec/apache2/libphp7.so"):
             return True
@@ -1226,8 +1221,11 @@ class Port(object):
         return re.sub(r'(?:.|\n)*Server version: Apache/(\d+\.\d+)(?:.|\n)*', r'\1', config)
 
     def _debian_php_version(self):
-        if self._is_debian_php_version_7():
-            return "-php7"
+        if self._filesystem.exists("/usr/lib/apache2/modules/libphp7.0.so"):
+            return "-php7.0"
+        elif self._filesystem.exists("/usr/lib/apache2/modules/libphp7.1.so"):
+            return "-php7.1"
+        _log.error("No libphp7.x.so found")
         return ""
 
     def _darwin_php_version(self):
index e761c40..500bcc6 100755 (executable)
@@ -156,7 +156,7 @@ function installDependenciesWithApt {
         dbus-x11 \
         gdb \
         libapache2-mod-bw \
-        $(aptIfElse libapache2-mod-php7.0 libapache2-mod-php5) \
+        libapache2-mod-php \
         libcgi-pm-perl \
         libgpg-error-dev \
         psmisc \
index 7630552..3d1fde1 100755 (executable)
@@ -92,7 +92,7 @@ function installDependenciesWithApt {
         curl \
         gdb \
         libapache2-mod-bw \
-        $(aptIfElse libapache2-mod-php7.0 libapache2-mod-php5) \
+        libapache2-mod-php \
         libcgi-pm-perl \
         psmisc \
         pulseaudio-utils \