[WPE] require python3-setuptools for meson build in jhbuild
authorcommit-queue@webkit.org <commit-queue@webkit.org@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Tue, 5 Feb 2019 17:44:58 +0000 (17:44 +0000)
committercommit-queue@webkit.org <commit-queue@webkit.org@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Tue, 5 Feb 2019 17:44:58 +0000 (17:44 +0000)
https://bugs.webkit.org/show_bug.cgi?id=194287

Patch by Olivier Blin <olivier.blin@softathome.com> on 2019-02-05
Reviewed by Philippe Normand.

python3-setuptools is needed to build meson in jhbuild.
It is already required by the GTK port.

* wpe/install-dependencies:

git-svn-id: https://svn.webkit.org/repository/webkit/trunk@240978 268f45cc-cd09-0410-ab3c-d52691b4dbfc

Tools/ChangeLog
Tools/wpe/install-dependencies

index 5288226..77de01e 100644 (file)
@@ -1,3 +1,15 @@
+2019-02-05  Olivier Blin  <olivier.blin@softathome.com>
+
+        [WPE] require python3-setuptools for meson build in jhbuild
+        https://bugs.webkit.org/show_bug.cgi?id=194287
+
+        Reviewed by Philippe Normand.
+
+        python3-setuptools is needed to build meson in jhbuild.
+        It is already required by the GTK port.
+
+        * wpe/install-dependencies:
+
 2019-02-05  Aakash Jain  <aakash_jain@apple.com>
 
         [ews-app] Add method to save BuilderMapping to database
index 75ef7fc..4646db9 100755 (executable)
@@ -131,6 +131,7 @@ function installDependenciesWithApt {
         libxrandr-dev \
         libwayland-dev \
         luajit \
+        python3-setuptools \
         yasm"
 
     # These are dependencies necessary for using webkit-patch
@@ -223,6 +224,7 @@ function installDependenciesWithPacman {
         opus \
         orc \
         perl-xml-libxml \
+        python3-setuptools \
         util-linux \
         v4l-utils \
         xorg-xrandr \
@@ -316,6 +318,7 @@ function installDependenciesWithDnf {
         orc-devel \
         perl-XML-LibXML \
         pulseaudio-libs-devel \
+        python3-setuptools \
         wayland-devel \
         yasm"