REGRESSION(r220515) [GTK][CMake] Build with ENABLE_GEOLOCATION fails on Debian Jessie
authorclopez@igalia.com <clopez@igalia.com@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Thu, 10 Aug 2017 16:33:31 +0000 (16:33 +0000)
committerclopez@igalia.com <clopez@igalia.com@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Thu, 10 Aug 2017 16:33:31 +0000 (16:33 +0000)
https://bugs.webkit.org/show_bug.cgi?id=175426

Reviewed by Carlos Garcia Campos.

.:

Fix the pkg-config file name.
We really require geoclue-2.0 and not libgeoclue-2.0.

* Source/cmake/FindGeoClue2.cmake:

Tools:

* gtk/install-dependencies: libgeoclue-dev packages not really needed on Debian/Ubuntu.

git-svn-id: https://svn.webkit.org/repository/webkit/trunk@220529 268f45cc-cd09-0410-ab3c-d52691b4dbfc

ChangeLog
Source/cmake/FindGeoClue2.cmake
Tools/ChangeLog
Tools/gtk/install-dependencies

index b87747c..e5d7d04 100644 (file)
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,15 @@
+2017-08-10  Carlos Alberto Lopez Perez  <clopez@igalia.com>
+
+        REGRESSION(r220515) [GTK][CMake] Build with ENABLE_GEOLOCATION fails on Debian Jessie
+        https://bugs.webkit.org/show_bug.cgi?id=175426
+
+        Reviewed by Carlos Garcia Campos.
+
+        Fix the pkg-config file name.
+        We really require geoclue-2.0 and not libgeoclue-2.0.
+
+        * Source/cmake/FindGeoClue2.cmake:
+
 2017-08-09  Michael Catanzaro  <mcatanzaro@igalia.com>
 
         [GTK] Remove support for geoclue1
index fd6c6cf..3143b44 100644 (file)
@@ -31,7 +31,7 @@
 # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
 
 find_package(PkgConfig)
-pkg_check_modules(GEOCLUE2 libgeoclue-2.0)
+pkg_check_modules(GEOCLUE2 geoclue-2.0)
 
 set(VERSION_OK FALSE)
 if (GEOCLUE2_VERSION)
index 5e9e6b4..4a90d86 100644 (file)
@@ -1,3 +1,12 @@
+2017-08-10  Carlos Alberto Lopez Perez  <clopez@igalia.com>
+
+        REGRESSION(r220515) [GTK][CMake] Build with ENABLE_GEOLOCATION fails on Debian Jessie
+        https://bugs.webkit.org/show_bug.cgi?id=175426
+
+        Reviewed by Carlos Garcia Campos.
+
+        * gtk/install-dependencies: libgeoclue-dev packages not really needed on Debian/Ubuntu.
+
 2017-08-10  Ms2ger  <Ms2ger@igalia.com>
 
         Add Ms2ger as contributor.
index 71ab470..e939b67 100755 (executable)
@@ -109,7 +109,6 @@ function installDependenciesWithApt {
         libfaad-dev \
         libffi-dev \
         $(aptIfElse libgcrypt20-dev libgcrypt11-dev) \
-        $(aptIfElse libgeoclue-2-dev libgeoclue-dev) \
         libgirepository1.0-dev \
         libgl1-mesa-dev \
         libgl1-mesa-glx \