master.cfg unittest cleanup: Show DeprecationWarnings with python >= 2.7 too
authorossy@webkit.org <ossy@webkit.org@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Sun, 12 Aug 2012 11:38:12 +0000 (11:38 +0000)
committerossy@webkit.org <ossy@webkit.org@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Sun, 12 Aug 2012 11:38:12 +0000 (11:38 +0000)
https://bugs.webkit.org/show_bug.cgi?id=90161

Reviewed by Eric Seidel.

* BuildSlaveSupport/build.webkit.org-config/mastercfg_unittest.py:

git-svn-id: https://svn.webkit.org/repository/webkit/trunk@125372 268f45cc-cd09-0410-ab3c-d52691b4dbfc

Tools/BuildSlaveSupport/build.webkit.org-config/mastercfg_unittest.py
Tools/ChangeLog

index 813ff22..8573440 100755 (executable)
@@ -5,6 +5,10 @@ import os
 import StringIO
 import unittest
 
+# Show DepricationWarnings come from buildbot - it isn't default with Python 2.7 or newer.
+# See https://bugs.webkit.org/show_bug.cgi?id=90161 for details.
+import warnings
+warnings.simplefilter('default')
 
 class BuildBotConfigLoader(object):
     def _add_webkitpy_to_sys_path(self):
index f8a5d2e..45311fd 100644 (file)
@@ -1,3 +1,12 @@
+2012-08-12  Csaba Osztrogon√°c  <ossy@webkit.org>
+
+        master.cfg unittest cleanup: Show DeprecationWarnings with python >= 2.7 too
+        https://bugs.webkit.org/show_bug.cgi?id=90161
+
+        Reviewed by Eric Seidel.
+
+        * BuildSlaveSupport/build.webkit.org-config/mastercfg_unittest.py:
+
 2012-08-12  Simon Hausmann  <simon.hausmann@nokia.com>
 
         [Qt] Unreviewed trivial build fix: Newer Qt versions don't implicitly include qwindowsysteminterface.h