[EFL][jhbuild] Build the GStreamer-related dependencies with the "configure" script
authorcommit-queue@webkit.org <commit-queue@webkit.org@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Mon, 14 Jan 2013 13:52:01 +0000 (13:52 +0000)
committercommit-queue@webkit.org <commit-queue@webkit.org@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Mon, 14 Jan 2013 13:52:01 +0000 (13:52 +0000)
https://bugs.webkit.org/show_bug.cgi?id=106573

Patch by Raphael Kubo da Costa <raphael.kubo.da.costa@intel.com> on 2013-01-14
Reviewed by Philippe Normand.

Similarly to what's been described in bug 106569, we're building
from release tarballs, so there's no reason to regenerate the
autoconf-related stuff with autogen.sh, especially since we might
run into trouble with automake 1.13 and deprecated macros.

* efl/jhbuild.modules:

git-svn-id: https://svn.webkit.org/repository/webkit/trunk@139612 268f45cc-cd09-0410-ab3c-d52691b4dbfc

Tools/ChangeLog
Tools/efl/jhbuild.modules

index fa9d72f..b721ec7 100644 (file)
@@ -1,3 +1,17 @@
+2013-01-14  Raphael Kubo da Costa  <raphael.kubo.da.costa@intel.com>
+
+        [EFL][jhbuild] Build the GStreamer-related dependencies with the "configure" script
+        https://bugs.webkit.org/show_bug.cgi?id=106573
+
+        Reviewed by Philippe Normand.
+
+        Similarly to what's been described in bug 106569, we're building
+        from release tarballs, so there's no reason to regenerate the
+        autoconf-related stuff with autogen.sh, especially since we might
+        run into trouble with automake 1.13 and deprecated macros.
+
+        * efl/jhbuild.modules:
+
 2013-01-14  Jocelyn Turcotte  <jocelyn.turcotte@digia.com>
 
         [Qt] The Qt's configuration isn't honoured regarding the use of the system libpng and libjpeg
index 305ba37..49dba32 100644 (file)
             md5sum="c62106f02ee00b6437f0fb9d370c1093"/>
   </autotools>
 
-  <autotools id="gstreamer">
+  <autotools id="gstreamer" autogen-sh="configure">
     <branch repo="gstreamer"
             module="gstreamer/gstreamer-1.0.5.tar.xz" version="1.0.5"
             hash="sha256:26c2827567f09a46d0a3bc1e7f8696b2ae72b047306539178079abae487c5b77"/>
   </autotools>
 
-  <autotools id="gst-plugins-base" autogenargs="--disable-examples --enable-theora --enable-vorbis">
+  <autotools id="gst-plugins-base"
+             autogen-sh="configure"
+             autogenargs="--disable-examples --enable-theora --enable-vorbis">
     <dependencies>
       <dep package="gstreamer"/>
     </dependencies>
             hash="sha256:37ce6e09b99ef3879111c861ee5090582b4fd4c764e81ab6eb2b2b4dd77d7173"/>
   </autotools>
 
-  <autotools id="gst-plugins-good" autogenargs="--disable-examples --enable-pulse">
+  <autotools id="gst-plugins-good"
+             autogen-sh="configure"
+             autogenargs="--disable-examples --enable-pulse">
     <dependencies>
       <dep package="cairo"/>
       <dep package="gst-plugins-base"/>
             hash="sha256:53bd0b848e7896f1b22548ca4e8be56cf425e5100e121c472dff8272d5140bc5"/>
   </autotools>
 
-  <autotools id="gst-plugins-bad" autogenargs="--disable-examples --enable-faad">
+  <autotools id="gst-plugins-bad"
+             autogen-sh="configure"
+             autogenargs="--disable-examples --enable-faad">
     <dependencies>
       <dep package="gst-plugins-base"/>
     </dependencies>
             hash="sha256:2e8f5b9a2fd274142d0a916b6425b9466028978b85858dc835dc80de744b276a"/>
   </autotools>
 
-  <autotools id="gst-libav" autogenargs="--with-libav-extra-configure='--disable-yasm'">
+  <autotools id="gst-libav"
+             autogen-sh="configure"
+             autogenargs="--with-libav-extra-configure='--disable-yasm'">
     <dependencies>
       <dep package="gst-plugins-base"/>
     </dependencies>