List libtasn1 packages in GTK+ and WPE install-dependencies scripts
authorzandobersek@gmail.com <zandobersek@gmail.com@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Wed, 21 Jun 2017 07:09:53 +0000 (07:09 +0000)
committerzandobersek@gmail.com <zandobersek@gmail.com@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Wed, 21 Jun 2017 07:09:53 +0000 (07:09 +0000)
as one of the dependencies required to build the product.

Rubber-stamped by Carlos Garcia Campos.

* gtk/install-dependencies:
* wpe/install-dependencies:

git-svn-id: https://svn.webkit.org/repository/webkit/trunk@218627 268f45cc-cd09-0410-ab3c-d52691b4dbfc

Tools/ChangeLog
Tools/gtk/install-dependencies
Tools/wpe/install-dependencies

index 239b3f9..4e4ffbe 100644 (file)
@@ -1,3 +1,13 @@
+2017-06-21  Zan Dobersek  <zdobersek@igalia.com>
+
+        List libtasn1 packages in GTK+ and WPE install-dependencies scripts
+        as one of the dependencies required to build the product.
+
+        Rubber-stamped by Carlos Garcia Campos.
+
+        * gtk/install-dependencies:
+        * wpe/install-dependencies:
+
 2017-06-20  Myles C. Maxfield  <mmaxfield@apple.com>
 
         Disable font variations on macOS Sierra and iOS 10
index 006766c..aa1d149 100755 (executable)
@@ -65,6 +65,7 @@ function installDependenciesWithBrew {
          libcroco \
          libgcrypt \
          libgpg-error \
+         libtasn1 \
          libtiff \
          libtool \
          ninja \
@@ -130,6 +131,7 @@ function installDependenciesWithApt {
         libsoup2.4-dev \
         libsqlite3-dev \
         libsrtp0-dev \
+        libtasn1-6-dev \
         libtheora-dev \
         libtool \
         libvorbis-dev \
@@ -279,6 +281,7 @@ function installDependenciesWithPacman {
         libsoup \
         libsrtp \
         sqlite \
+        libtasn1 \
         libtheora \
         libtool \
         libvorbis \
@@ -405,6 +408,7 @@ function installDependenciesWithDnf {
         libsecret-devel \
         libsoup-devel \
         libsrtp-devel \
+        libtasn1-devel \
         libtheora-devel \
         libv4l-devel \
         libvorbis-devel \
index 50fc213..e349d2d 100755 (executable)
@@ -72,6 +72,7 @@ function installDependenciesWithApt {
         libjpeg-dev \
         $(aptIfElse libpng-dev libpng12-dev) \
         libsqlite3-dev \
+        libtasn1-6-dev \
         libtool \
         libwebp-dev \
         libxml2-dev \
@@ -148,6 +149,7 @@ function installDependenciesWithPacman {
         itstool \
         libjpeg-turbo \
         libpng \
+        libtasn1 \
         libtool \
         libwebp \
         libxml2 \
@@ -227,6 +229,7 @@ function installDependenciesWithDnf {
         libicu-devel \
         libjpeg-turbo-devel \
         libpng-devel \
+        libtasn1-devel \
         libtool \
         libwebp-devel \
         libxml2-devel \