[GTK][WPE] force libpsl build to use ICU in jhbuild
authorcommit-queue@webkit.org <commit-queue@webkit.org@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Wed, 6 Feb 2019 13:47:50 +0000 (13:47 +0000)
committercommit-queue@webkit.org <commit-queue@webkit.org@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Wed, 6 Feb 2019 13:47:50 +0000 (13:47 +0000)
https://bugs.webkit.org/show_bug.cgi?id=194288

Patch by Olivier Blin <olivier.blin@softathome.com> on 2019-02-06
Reviewed by Carlos Garcia Campos.

* gtk/jhbuild.modules:
Require ICU for libpsl build in jhbuild, like done in WPE.

git-svn-id: https://svn.webkit.org/repository/webkit/trunk@241016 268f45cc-cd09-0410-ab3c-d52691b4dbfc

Tools/ChangeLog
Tools/gtk/jhbuild.modules

index e4c2196..6dce07b 100644 (file)
@@ -1,3 +1,13 @@
+2019-02-06  Olivier Blin  <olivier.blin@softathome.com>
+
+        [GTK][WPE] force libpsl build to use ICU in jhbuild
+        https://bugs.webkit.org/show_bug.cgi?id=194288
+
+        Reviewed by Carlos Garcia Campos.
+
+        * gtk/jhbuild.modules:
+        Require ICU for libpsl build in jhbuild, like done in WPE.
+
 2019-02-06  Michael Catanzaro  <mcatanzaro@igalia.com>
 
         REGRESSION(r240785): [SOUP] Broke cookie persistent storage
index 948cbf9..1ecebc3 100644 (file)
 
   <autotools id="libpsl"
              autogenargs="--enable-runtime=libicu --enable-builtin=libicu">
+    <dependencies>
+      <dep package="icu"/>
+    </dependencies>
     <branch module="rockdaboot/libpsl/releases/download/libpsl-${version}/libpsl-${version}.tar.gz"
             version="0.20.2"
             repo="github-tarball"