[Qt] Auto-generate the module pri file for QtWebKit
authorvestbo@webkit.org <vestbo@webkit.org@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Mon, 17 Sep 2012 13:32:37 +0000 (13:32 +0000)
committervestbo@webkit.org <vestbo@webkit.org@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Mon, 17 Sep 2012 13:32:37 +0000 (13:32 +0000)
Reviewed by Simon Hausmann.

git-svn-id: https://svn.webkit.org/repository/webkit/trunk@128751 268f45cc-cd09-0410-ab3c-d52691b4dbfc

ChangeLog
Source/api.pri
Tools/ChangeLog
Tools/qmake/qt_webkit.pri [deleted file]

index d23bdac..4279967 100644 (file)
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,11 @@
+2012-09-17  Tor Arne Vestbø  <tor.arne.vestbo@nokia.com>
+
+        [Qt] Auto-generate the module pri file for QtWebKit
+
+        Reviewed by Simon Hausmann.
+
+        * Source/api.pri:
+
 2012-09-14  Julien Chaffraix  <jchaffraix@webkit.org>
 
         Revert r127457 and following fixes due to several hit-testing regressions
index 6f32345..0053268 100644 (file)
@@ -29,7 +29,6 @@ use?(3D_GRAPHICS): WEBKIT += angle
 load(webkit_modules)
 
 MODULE = webkit
-MODULE_PRI = ../Tools/qmake/qt_webkit.pri
 
 # This is the canonical list of dependencies for the public API of
 # the QtWebKit library, and will end up in the library's prl file.
index c33afb1..469f5ff 100644 (file)
@@ -1,3 +1,11 @@
+2012-09-17  Tor Arne Vestbø  <tor.arne.vestbo@nokia.com>
+
+        [Qt] Auto-generate the module pri file for QtWebKit
+
+        Reviewed by Simon Hausmann.
+
+        * qmake/qt_webkit.pri: Removed.
+
 2012-09-14  Dirk Pranke  <dpranke@chromium.org>
 
         nrwt: --additional-platform-dir is broken on chromium ports
diff --git a/Tools/qmake/qt_webkit.pri b/Tools/qmake/qt_webkit.pri
deleted file mode 100644 (file)
index e221bd2..0000000
+++ /dev/null
@@ -1,28 +0,0 @@
-# These variables define the library version, which is based on the original
-# Qt library version. It is not related to the release-version of QtWebKit.
-QT.webkit.MAJOR_VERSION = 5
-QT.webkit.MINOR_VERSION = 0
-QT.webkit.PATCH_VERSION = 0
-QT.webkit.VERSION = 5.0.0
-
-QT.webkit.name = QtWebKit
-QT.webkit.bins = $$QT_MODULE_BIN_BASE
-QT.webkit.includes = $$QT_MODULE_INCLUDE_BASE $$QT_MODULE_INCLUDE_BASE/QtWebKit
-QT.webkit.imports = $$QT_MODULE_IMPORT_BASE
-QT.webkit.private_includes = $$QT_MODULE_INCLUDE_BASE/$$QT.webkit.name/$$QT.webkit.VERSION $$QT_MODULE_INCLUDE_BASE/$$QT.webkit.name/$$QT.webkit.VERSION/$$QT.webkit.name
-QT.webkit.sources = $$QT_MODULE_BASE
-QT.webkit.libs = $$QT_MODULE_LIB_BASE
-QT.webkit.depends = core gui opengl network
-
-!contains(QT_CONFIG, modular)|contains(QT_ELIGIBLE_MODULES, webkit) {
-    QT_CONFIG += webkit
-} else {
-    warning("Attempted to include $$QT.webkit.name in the build, but it was not enabled in configure.")
-}
-
-# This is the old syntax for the WebKit version defines.
-# We keep them around in case someone was using them.
-QT_WEBKIT_VERSION = $$QT.webkit.VERSION
-QT_WEBKIT_MAJOR_VERSION = $$QT.webkit.MAJOR_VERSION
-QT_WEBKIT_MINOR_VERSION = $$QT.webkit.MINOR_VERSION
-QT_WEBKIT_PATCH_VERSION = $$QT.webkit.PATCH_VERSION