[GTK] Bump the GLib and GTK+ dependencies in jhbuild-wayland.modules
authorzandobersek@gmail.com <zandobersek@gmail.com@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Wed, 18 Jun 2014 17:48:25 +0000 (17:48 +0000)
committerzandobersek@gmail.com <zandobersek@gmail.com@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Wed, 18 Jun 2014 17:48:25 +0000 (17:48 +0000)
https://bugs.webkit.org/show_bug.cgi?id=133971

Reviewed by Martin Robinson.

* gtk/jhbuild-wayland.modules: Bump the GTK+ dependency that's required for
building for the Wayland target. The latest 3.12 version is required to match
the xdg_shell protocol version used in Weston 1.5. GLib dependency is bumped
as well due to GTK+ depending on a newer version.

git-svn-id: https://svn.webkit.org/repository/webkit/trunk@170105 268f45cc-cd09-0410-ab3c-d52691b4dbfc

Tools/ChangeLog
Tools/gtk/jhbuild-wayland.modules

index 6751af7..74baf5f 100644 (file)
@@ -1,3 +1,15 @@
+2014-06-18  Zan Dobersek  <zdobersek@igalia.com>
+
+        [GTK] Bump the GLib and GTK+ dependencies in jhbuild-wayland.modules
+        https://bugs.webkit.org/show_bug.cgi?id=133971
+
+        Reviewed by Martin Robinson.
+
+        * gtk/jhbuild-wayland.modules: Bump the GTK+ dependency that's required for
+        building for the Wayland target. The latest 3.12 version is required to match
+        the xdg_shell protocol version used in Weston 1.5. GLib dependency is bumped
+        as well due to GTK+ depending on a newer version.
+
 2014-06-17  Ryuan Choi  <ryuan.choi@samsung.com>
 
         [EFL] Turn on NOSNIFF in FeatureList.pm
index 81b41f6..f248c20 100644 (file)
@@ -25,9 +25,9 @@
       <dep package="at-spi2-atk"/>
       <dep package="gdk-pixbuf"/>
     </dependencies>
-    <branch module="/pub/GNOME/sources/gtk+/3.10/gtk+-3.10.0.tar.xz" version="3.10.0"
+    <branch module="/pub/GNOME/sources/gtk+/3.12/gtk+-3.12.0.tar.xz" version="3.12.0"
             repo="ftp.gnome.org"
-            hash="sha256:6559feb360cd935d341cd7a0b69a72f8f4346ed6ee9b7c4040c02b73b75c53fe"/>
+            hash="sha256:eb69741cd4029b5a1ac9cf04d9de55dcf9e30777a63891750f5d20cc554b6e4b"/>
   </autotools>
 
   <autotools id="glib"
@@ -36,8 +36,8 @@
     <dependencies>
       <dep package="libffi"/>
     </dependencies>
-    <branch module="/pub/GNOME/sources/glib/2.37/glib-2.37.6.tar.xz" version="2.37.6"
+    <branch module="/pub/GNOME/sources/glib/2.40/glib-2.40.0.tar.xz" version="2.40.0"
             repo="ftp.gnome.org"
-            hash="sha256:01e1de3179cc58dafc0c950363530fccdefc6dda32a25aed96dd24dc23b83165"/>
+            hash="sha256:0d27f195966ecb1995dcce0754129fd66ebe820c7cd29200d264b02af1aa28b5"/>
   </autotools>
 </moduleset>