Follow-up patch for r189343.
authorclopez@igalia.com <clopez@igalia.com@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Fri, 4 Sep 2015 11:48:08 +0000 (11:48 +0000)
committerclopez@igalia.com <clopez@igalia.com@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Fri, 4 Sep 2015 11:48:08 +0000 (11:48 +0000)
https://bugs.webkit.org/show_bug.cgi?id=148795

Rubber-stamped by Csaba Osztrogon√°c.

* Source/cmake/WebKitCommon.cmake: Relax the Ruby version requirement
to 1.9, since this seems to be enough to fix the build failure.
And 2.0 may cause problems for developers using some distributions like Ubuntu.

git-svn-id: https://svn.webkit.org/repository/webkit/trunk@189345 268f45cc-cd09-0410-ab3c-d52691b4dbfc

ChangeLog
Source/cmake/WebKitCommon.cmake

index 3060e86..2a587bc 100644 (file)
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,14 @@
+2015-09-04  Carlos Alberto Lopez Perez  <clopez@igalia.com>
+
+        Follow-up patch for r189343.
+        https://bugs.webkit.org/show_bug.cgi?id=148795
+
+        Rubber-stamped by Csaba Osztrogon√°c.
+
+        * Source/cmake/WebKitCommon.cmake: Relax the Ruby version requirement
+        to 1.9, since this seems to be enough to fix the build failure.
+        And 2.0 may cause problems for developers using some distributions like Ubuntu.
+
 2015-09-04  Emanuele Aina  <emanuele.aina@collabora.com>
 
         [CMake] Trigger the memory-reduction tricks on armhf too
index 4d3638c..321afa8 100644 (file)
@@ -17,9 +17,9 @@ find_package(PythonInterp 2.7.0 REQUIRED)
 # We cannot check for RUBY_FOUND because it is set only when the full package is installed and
 # the only thing we need is the interpreter. Unlike Python, cmake does not provide a macro
 # for finding only the Ruby interpreter.
-find_package(Ruby 2.0)
-if (NOT RUBY_EXECUTABLE OR RUBY_VERSION VERSION_LESS 2.0)
-    message(FATAL_ERROR "Ruby 2.0 or higher is required.")
+find_package(Ruby 1.9)
+if (NOT RUBY_EXECUTABLE OR RUBY_VERSION VERSION_LESS 1.9)
+    message(FATAL_ERROR "Ruby 1.9 or higher is required.")
 endif ()
 
 include(WebKitMacros)