[iOS] Wireless playback button not blue when active
authorjer.noble@apple.com <jer.noble@apple.com@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Fri, 2 May 2014 20:03:41 +0000 (20:03 +0000)
committerjer.noble@apple.com <jer.noble@apple.com@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Fri, 2 May 2014 20:03:41 +0000 (20:03 +0000)
https://bugs.webkit.org/show_bug.cgi?id=132473

Reviewed by Simon Fraser.

The playback button's class was being set to 'undefined', due to Controller.ClassNames.active being undefined.

* Modules/mediacontrols/mediaControlsApple.js:

git-svn-id: https://svn.webkit.org/repository/webkit/trunk@168186 268f45cc-cd09-0410-ab3c-d52691b4dbfc

Source/WebCore/ChangeLog
Source/WebCore/Modules/mediacontrols/mediaControlsApple.js

index d0819a9..fba1471 100644 (file)
@@ -1,3 +1,14 @@
+2014-05-02  Jer Noble  <jer.noble@apple.com>
+
+        [iOS] Wireless playback button not blue when active
+        https://bugs.webkit.org/show_bug.cgi?id=132473
+
+        Reviewed by Simon Fraser.
+
+        The playback button's class was being set to 'undefined', due to Controller.ClassNames.active being undefined.
+
+        * Modules/mediacontrols/mediaControlsApple.js:
+
 2014-05-02  Alexey Proskuryakov  <ap@apple.com>
 
         Don't abuse Blob deserialization constructor in WebSocket
index 68fe6c6..a37f79d 100644 (file)
@@ -68,6 +68,7 @@ Controller.prototype = {
     MaximumSeekRate: 8,
     SeekDelay: 1500,
     ClassNames: {
+        active: 'active',
         exit: 'exit',
         hidden: 'hidden',
         hiding: 'hiding',