[GTK] Enable WebKit2 build by default (again)
authorkov@webkit.org <kov@webkit.org@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Mon, 7 May 2012 01:31:20 +0000 (01:31 +0000)
committerkov@webkit.org <kov@webkit.org@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Mon, 7 May 2012 01:31:20 +0000 (01:31 +0000)
https://bugs.webkit.org/show_bug.cgi?id=85750

* configure.ac: enable wk2 build by default.

git-svn-id: https://svn.webkit.org/repository/webkit/trunk@116256 268f45cc-cd09-0410-ab3c-d52691b4dbfc

ChangeLog
configure.ac

index dc5f190..685c054 100644 (file)
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,10 @@
+2012-05-06  Gustavo Noronha Silva  <gns@gnome.org>
+
+        [GTK] Enable WebKit2 build by default (again)
+        https://bugs.webkit.org/show_bug.cgi?id=85750
+
+        * configure.ac: enable wk2 build by default.
+
 2012-05-06  Gyuyoung Kim  <gyuyoung.kim@samsung.com>
 
         Convert isPageBoxVisible to use Internals interface.
index 324effb..7533281 100644 (file)
@@ -1244,10 +1244,12 @@ if test "$enable_video" = "yes"; then
 fi
 
 # WebKit2
+# If you change the default here, please also make sure the assumptions made
+# in Tools/Scripts/webkitdirs.pm:buildAutotoolsProject still make sense.
 AC_MSG_CHECKING([whether to build Webkit2])
 AC_ARG_ENABLE(webkit2,
-    AC_HELP_STRING([--enable-webkit2], [build webkit2 [default=no]]),
-    [], [enable_webkit2="no"])
+    AC_HELP_STRING([--enable-webkit2], [build webkit2 [default=yes]]),
+    [], [enable_webkit2="yes"])
 AC_MSG_RESULT([$enable_webkit2])
 if test "$enable_webkit2" = "yes"; then
    if test "$GTK_API_VERSION" = "2.0"; then