[Chromium] Disable c++0x compatibility warnings in JavaScriptCore.gyp when building...
authorpeter@chromium.org <peter@chromium.org@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Fri, 22 Jun 2012 16:20:33 +0000 (16:20 +0000)
committerpeter@chromium.org <peter@chromium.org@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Fri, 22 Jun 2012 16:20:33 +0000 (16:20 +0000)
commitf9539ece65500b5658e6c65666eae070f44843db
tree8e670c12c969d2ee6846b46785c7224b0c3582f7
parentc9c4ac634ee7d569a23b8a054e533202618f8b40
[Chromium] Disable c++0x compatibility warnings in JavaScriptCore.gyp when building for Android
https://bugs.webkit.org/show_bug.cgi?id=88853

Reviewed by Steve Block.

The Android exclusions were necessary to fix a gyp generation error, as
the gcc_version variable wasn't being defined for Android. Remove these
exceptions when Chromium is able to define the gcc_version variable.

Source/JavaScriptCore:

* JavaScriptCore.gyp/JavaScriptCore.gyp:

Source/WebCore:

* WebCore.gyp/WebCore.gyp:

Source/WebKit/chromium:

* WebKit.gyp:
* WebKitUnitTests.gyp:

Source/WTF:

* WTF.gyp/WTF.gyp:

Tools:

* DumpRenderTree/DumpRenderTree.gyp/DumpRenderTree.gyp:

git-svn-id: https://svn.webkit.org/repository/webkit/trunk@121028 268f45cc-cd09-0410-ab3c-d52691b4dbfc
Source/JavaScriptCore/ChangeLog
Source/JavaScriptCore/JavaScriptCore.gyp/JavaScriptCore.gyp
Source/WTF/ChangeLog
Source/WTF/WTF.gyp/WTF.gyp
Source/WebCore/ChangeLog
Source/WebCore/WebCore.gyp/WebCore.gyp
Source/WebKit/chromium/ChangeLog
Source/WebKit/chromium/WebKit.gyp
Source/WebKit/chromium/WebKitUnitTests.gyp
Tools/ChangeLog
Tools/DumpRenderTree/DumpRenderTree.gyp/DumpRenderTree.gyp