[GTK] Use LD_LIBRARY_PATH to make g-ir-scanner use the newly-built
authorberto@igalia.com <berto@igalia.com@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Tue, 25 Nov 2014 14:29:09 +0000 (14:29 +0000)
committerberto@igalia.com <berto@igalia.com@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Tue, 25 Nov 2014 14:29:09 +0000 (14:29 +0000)
commitf161145837829c640fa533acac148c4a4a495f23
tree38f99dd68bf2ac86813352b62373a1bce4e21443
parent6ce02034973cbc75584d0f2eb196f381602dc3e1
[GTK] Use LD_LIBRARY_PATH to make g-ir-scanner use the newly-built
version of libraries when running the temporary executable
https://bugs.webkit.org/show_bug.cgi?id=138833

Patch by Ting-Wei Lan <lantw44@gmail.com> on 2014-11-25
Reviewed by Carlos Garcia Campos.

This patch modifies LD_LIBRARY_PATH to make sure the dynamic linker
find the correct version of libraries when running the temporary
executable to generate the .gir file.

* PlatformGTK.cmake:

git-svn-id: https://svn.webkit.org/repository/webkit/trunk@176540 268f45cc-cd09-0410-ab3c-d52691b4dbfc
Source/WebKit2/ChangeLog
Source/WebKit2/PlatformGTK.cmake