[WPE][CMake] The “install” target should install all public API headers
authoraperez@igalia.com <aperez@igalia.com@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Tue, 10 Oct 2017 11:27:40 +0000 (11:27 +0000)
committeraperez@igalia.com <aperez@igalia.com@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Tue, 10 Oct 2017 11:27:40 +0000 (11:27 +0000)
commite8e741cbaf894fa97cbe1ddbe4f456735255cb05
tree8f3519dd1ab7c33dd43228cdfba98c389f709f26
parentec9c9ea06f60f5f3032904c8157f30d8868e1f0c
[WPE][CMake] The “install” target should install all public API headers
https://bugs.webkit.org/show_bug.cgi?id=176475

Reviewed by Žan Doberšek.

Install the WPE port GLib-based API headers. The deprecated C API is still available,
but disabled by default behind the "EXPORT_DEPRECATED_WEBKIT2_C_API" CMake option.

* PlatformWPE.cmake: Always install "wpe-webkit.pc" and the GLib C API for WPE.

git-svn-id: https://svn.webkit.org/repository/webkit/trunk@223128 268f45cc-cd09-0410-ab3c-d52691b4dbfc
Source/WebKit/ChangeLog
Source/WebKit/PlatformWPE.cmake