[WPE] Remove libgbm dependency
authorzandobersek@gmail.com <zandobersek@gmail.com@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Tue, 24 Apr 2018 08:06:56 +0000 (08:06 +0000)
committerzandobersek@gmail.com <zandobersek@gmail.com@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Tue, 24 Apr 2018 08:06:56 +0000 (08:06 +0000)
commite781f5c11943d8e71929d3bb2a8ee8a74e640814
tree7f64eacdb38dc3da84b97d7737157798f6e49420
parent3a0431259a8094910e8b6382b095541edde11172
[WPE] Remove libgbm dependency
https://bugs.webkit.org/show_bug.cgi?id=184906

Reviewed by Carlos Garcia Campos.

.:

Remove the libgbm CMake search module. It's not necessary anymore
after r230562.

* Source/cmake/FindLibGBM.cmake: Removed.

Tools:

Stop searching for libgbm, using its compiler flags for the
HeadlessViewBackend compilation and linking against the .so object.
This is not necessary anymore after r230562 switched to a different
backend implementation for testing.

* wpe/HeadlessViewBackend/CMakeLists.txt:
* wpe/install-dependencies:

git-svn-id: https://svn.webkit.org/repository/webkit/trunk@230949 268f45cc-cd09-0410-ab3c-d52691b4dbfc
ChangeLog
Source/cmake/FindLibGBM.cmake [deleted file]
Tools/ChangeLog
Tools/wpe/HeadlessViewBackend/CMakeLists.txt
Tools/wpe/install-dependencies